sg函数的应用 poj--Cutting Game

Cutting Game
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4036 Accepted: 1501

Description

Urej loves to play various types of dull games. He usually asks other people to play with him. He says that playing those games can show his extraordinary wit. Recently Urej takes a great interest in a new game, and Erif Nezorf becomes the victim. To get away from suffering playing such a dull game, Erif Nezorf requests your help. The game uses a rectangular paper that consists of W*H grids. Two players cut the paper into two pieces of rectangular sections in turn. In each turn the player can cut either horizontally or vertically, keeping every grids unbroken. After N turns the paper will be broken into N+1 pieces, and in the later turn the players can choose any piece to cut. If one player cuts out a piece of paper with a single grid, he wins the game. If these two people are both quite clear, you should write a problem to tell whether the one who cut first can win or not.

Input

The input contains multiple test cases. Each test case contains only two integers W and H (2 <= W, H <= 200) in one line, which are the width and height of the original paper.

Output

For each test case, only one line should be printed. If the one who cut first can win the game, print "WIN", otherwise, print "LOSE".

Sample Input

2 2
3 2
4 2

Sample Output

LOSE
LOSE

WIN

题目大意:

剪纸游戏,减一张长方形方格纸,每次只能横减或竖减,谁先减除一个单个的方格就赢

思路:首先一定是考虑如何打一下sg函数的表,关键是找出的它的所有后继的情况,当一个x*y的方格纸的后继可以分为两种情况

(1)横减,所有的后继情况为x从2~x-2(一定不能减1,或者x-1,那样就输了)

(2)竖减同理

打完表就解决了,当sg为0时后手赢,否则先手赢

ac代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int sg[205][205];
int get_sg(int x,int y)
{
    if(sg[x][y]!=-1)
    return sg[x][y];
    if(x==1&&y==1)
    return sg[x][y]=0;
    int vis[205];
    memset(vis,0,sizeof(vis));
    for(int i=2;i<x-1;i++)
    {
        int t=get_sg(x-i,y)^get_sg(i,y);
        vis[t]=1;
    }
    for(int i=2;i<y-1;i++)
    {
       int t=get_sg(x,y-i)^get_sg(x,i);
       vis[t]=1;
    }
    for(int i=0;;i++)
    if(vis[i]==0)
    return sg[x][y]=i;
}
int main()
{
    int x,y;
    memset(sg,-1,sizeof(sg));
    while(~scanf("%d%d",&x,&y))
    {
       if(get_sg(x,y)==0)
       printf("LOSE\n");
       else
       printf("WIN\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值