HDU1312 ZOJ2165 Red and Black【DFS】

232 篇文章 0 订阅
86 篇文章 9 订阅

 

Red and Black

 

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 22088    Accepted Submission(s): 13449

 

 

Problem Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

 

 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)

 

 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

 

 

Sample Input

 

6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0

 

 

Sample Output

 

45 59 6 13

 

 

Source

Asia 2004, Ehime (Japan), Japan Domestic

 

 

 

问题链接HDU1312 ZOJ2165 Red and Black

问题简述:(略)

问题分析:本题可以使用深度优先搜索求解。

程序说明

1.方向数组 使用方向数组后,各个方向的试探的程序就会变得简洁了,用循环处理即可。

2.避免重复搜索 将搜索过的节点设置为“#”(墙),可以避免重复搜索,能够简化程序逻辑。

3.设置边界 通过设置边界,可以免去矩阵(二维数组)的边界判断,简化了程序逻辑。

该问题与图遍历中寻找联通块问题基本上是同构的,算法思路一致。

每当找到一个可以到达的点,只需要计数加一,并且使用DFS算法把与其相邻的4个可以到达的点擦除即可(避免重复计数)。

 

这个程序是拷贝HDU1241 UVa572 Oil Deposits修改实现的,分分钟的事情。

 

 

AC的C语言程序如下:

 

/* HDU1312 ZOJ2165 Red and Black */

#include <stdio.h>
#include <memory.h>

#define DIRECTSIZE 4

struct direct {
    int drow;
    int dcol;
} direct[DIRECTSIZE] =
    {{0, -1}, {0, 1}, {-1, 0}, {1, 0}};

#define MAXN 20

char grid[MAXN+2][MAXN+2];

int count;

void dfs(int row, int col)
{
    int i;

    for(i=0; i<DIRECTSIZE; i++) {
        int nextrow = row + direct[i].drow;
        int nextcol = col + direct[i].dcol;

        if(grid[nextrow][nextcol] == '.') {
            count++;

            grid[nextrow][nextcol] = '#';

            dfs(nextrow, nextcol);
        }
    }
}

int main(void)
{
    int x, y, i, j;

    while(scanf("%d%d", &y, &x) != EOF) {
        // 判定结束条件
        if(x == 0 && y == 0)
            break;

        // 清零:边界清零
        memset(grid, 0, sizeof(grid));

        // 读入数据
        for(i=1; i<=x; i++)
            scanf("%s", grid[i]+1);

        // 计数清零
        count = 0;

        // 深度优先搜索
        for(i=1; i<=x; i++)
            for(j=1; j<=y; j++)
                if(grid[i][j] == '@') {
                    count++;
                    dfs(i, j);
                }

        // 输出结果
        printf("%d\n", count);
    }

    return 0;
}

 

 

 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值