NUC1178 Kickdown【水题】

Kickdown

时间限制: 1000ms 内存限制: 65536KB

问题描述
A research laboratory of a world-leading automobile company has received an order to create a special transmission mechanism, which allows for incredibly efficient kickdown — an operation of switching to lower gear. After several months of research engineers found that the most efficient solution requires special gears with teeth and cavities placed non-uniformly. They calculated the optimal flanks of the gears. Now they want to perform some experiments to prove their findings.The first phase of the experiment is done with planar toothed sections, not round-shaped gears. A section of length n consists of n units. The unit is either a cavity of height h or a tooth of height 2h. Two sections are required for the experiment: one to emulate master gear (with teeth at the bottom) and one for the driven gear (with teeth at the top).
There is a long stripe of width 3h in the laboratory and its length is enough for cutting two engaged sections together. The sections are irregular but they may still be put together if shifted along each other.
The stripe is made of an expensive alloy, so the engineers want to use as little of it as possible. You need to find the minimal length of the stripe which is enough for cutting both sections simultaneously.
输入描述
There are two lines in the input file, each contains a string to describe a section. The first line describes master section (teeth at the bottom) and the second line describes driven section (teeth at the top). Each character in a string represents one section unit — 1 for a cavity and 2 for a tooth. The sections can not be flipped or rotated.Each string is non-empty and its length does not exceed 100.
输出描述
Write a single integer number to the output file — the minimal length of the stripe required to cut off given sections.
样例输入
sample input #1
2112112112
2212112

sample input #2
12121212
21212121

sample input #3
2211221122
21212
样例输出
sample output #1
10

sample output #2
8

sample output #3
15
来源
Northeastern Europe 2006
提示
注意:上面只是给出三个例子。 需要注意 input 中的“ There are two lines in the input file,...” 只有一组测试数据。不要输入“sample input #1”等标识符 和输出 “sample output #1”等标识符。


问题分析:

这个问题和《UVA1588 UVALive3712 POJ3158 Kickdown》是同一个问题,代码拿过来用就AC了。

程序说明:

参见参考链接。

参考链接:UVA1588 UVALive3712 POJ3158 Kickdown

题记:

程序做多了,不定哪天遇见似曾相识的。


AC的C++程序如下:

/* UVA1588 UVALive3712 POJ3158 Kickdown */  
  
#include <stdio.h>  
#include <string.h>  
  
#define MIN(x, y) (((x)>(y))?(y):(x))  
  
#define MAXN 100  
  
char s[MAXN], t[MAXN];  
  
int main(void)  
{  
    int slen, tlen, ans1, ans2, i, j;  
  
    while(scanf("%s", s) != EOF) {  
        scanf("%s", t);  
  
        slen = strlen(s);  
        tlen = strlen(t);  
  
        /* s left, t right */  
        for(i=0; i<slen; i++) {  
            for(j=0; j<tlen && i+j<slen; j++) {  
                if(s[i+j] == '2' && t[j] == '2')  
                    break;  
            }  
            if(j == tlen || i+j == slen)  
                break;  
        }  
        ans1 = i + tlen;  
        if(ans1 < slen)  
            ans1 = slen;  
  
        /* t left, s right */  
        for(j=0; j<tlen; j++) {  
            for(i=0; i<slen && j+i<tlen; i++) {  
                if(t[j+i] == '2' && s[i] == '2')  
                    break;  
            }  
            if(i == slen || j+i == tlen)  
                break;  
        }  
        ans2 = j + slen;  
        if(ans2 < tlen)  
            ans2 = tlen;  
  
        printf("%d\n", MIN(ans1, ans2));  
    }  
  
    return 0;  
} 






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值