ZOJ3869 Ace of Aces【序列处理+水题】

Ace of Aces

Time Limit: 2 Seconds        Memory Limit: 65536 KB

There is a mysterious organization called Time-Space Administrative Bureau (TSAB) in the deep universe that we humans have not discovered yet. This year, the TSAB decided to elect an outstanding member from its elite troops. The elected guy will be honored with the title of "Ace of Aces".

After voting, the TSAB received N valid tickets. On each ticket, there is a number Ai denoting the ID of a candidate. The candidate with the most tickets nominated will be elected as the "Ace of Aces". If there are two or more candidates have the same number of nominations, no one will win.

Please write program to help TSAB determine who will be the "Ace of Aces".

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (1 <= N <= 1000). The next line contains N integers Ai (1 <= Ai <= 1000).

Output

For each test case, output the ID of the candidate who will be honored with "Ace of Aces". If no one win the election, output "Nobody" (without quotes) instead.

Sample Input
3
5
2 2 2 1 1
5
1 1 2 2 3
1
998
Sample Output
2
Nobody
998

Author:  JIANG, Kai
Source:  The 12th Zhejiang Provincial Collegiate Programming Contest



问题链接ZOJ3869 Ace of Aces

问题简述:参见上文。

问题分析

  这个题本质上是求出现次数最多的数,如果不存在则输出“Nobody”(没有最多次数,有一样多次数)。

  好在值的范围不大(1<=ai<=1000),找1000个桶把相同的数装在一起(计数),然后找出其出现次数最多和第二多的数。

程序说明:(略)

题记:(略)


AC的C++语言程序如下:

/* ZOJ3869 Ace of Aces */

#include <iostream>
#include <stdio.h>
#include <string.h>

using namespace std;

const int N = 1000;
int count[N+1];

int main()
{
    int t, n, ai, maxa, first, second;
    scanf("%d", &t);
    while(t--) {
        memset(count, 0, sizeof(count));

        scanf("%d", &n);
        maxa = 0;
        first = second = 0;
        for(int i=1; i<=n; i++) {
            scanf("%d", &ai);
            count[ai]++;
            if(count[ai] >= first) {
                maxa = ai;
                second = first;
                first = count[ai];
            }
        }

        if(first == second)
            printf("Nobody\n");
        else
            printf("%d\n", maxa);
    }

    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值