HDU1896 Stones【模拟+优先队列】

Stones

Time Limit: 5000/3000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 3015    Accepted Submission(s): 1951

Problem Description
Because of the wrong status of the bicycle, Sempr begin to walk east to west every morning and walk back every evening. Walking may cause a little tired, so Sempr always play some games this time.  
There are many stones on the road, when he meet a stone, he will throw it ahead as far as possible if it is the odd stone he meet, or leave it where it was if it is the even stone. Now give you some informations about the stones on the road, you are to tell me the distance from the start point to the farthest stone after Sempr walk by. Please pay attention that if two or more stones stay at the same position, you will meet the larger one(the one with the smallest Di, as described in the Input) first.
Input
In the first line, there is an Integer T(1<=T<=10), which means the test cases in the input file. Then followed by T test cases.  
For each test case, I will give you an Integer N(0<N<=100,000) in the first line, which means the number of stones on the road. Then followed by N lines and there are two integers Pi(0<=Pi<=100,000) and Di(0<=Di<=1,000) in the line, which means the position of the i-th stone and how far Sempr can throw it.
Output
Just output one line for one test case, as described in the Description.
Sample Input
  
  
2 2 1 5 2 4 2 1 5 6 6
Sample Output
  
  
11 12
Author
Sempr|CrazyBird|hust07p43
Source

问题链接HDU1896 Stones

问题简述

  Sempr走在路上时会玩一种游戏,遇见奇数块石头时将其扔到更远,遇到偶数块石头时则离开。问Sempr不会再遇到石头时,总共走了多少距离。

问题分析

  Sempr走在路上时,必然先遇到距离近的石头,所以需要用优先队列来表示问题。剩下的就是模拟走路的过程。

程序说明:(略)

题记:(略)

参考链接:(略)


AC的C++语言程序如下:

/* HDU1896 Stones */

#include <iostream>
#include <queue>
#include <stdio.h>

using namespace std;

struct _node {
    int pos;
    int dist;
    friend bool operator <(const _node &a,const _node &b) {
        if(a.pos == b.pos)
            return a.dist > b.dist;
        else
            return a.pos > b.pos;
    }
};

int main()
{
    int t, n;

    scanf("%d", &t);
    while(t--) {
        priority_queue <_node> q;
        _node t;

        scanf("%d", &n);
        for(int i=1; i<=n; i++) {
            scanf("%d%d", &t.pos, &t.dist);
            q.push(t);
        }

        bool odd = true;
        while(!q.empty()) {
            t = q.top();
            q.pop();

            if(odd) {       // 奇数时操作
                t.pos += t.dist;
                q.push(t);
            }
            odd = !odd;
        }

        printf("%d\n", t.pos);
    }

    return 0;
}




对于HDU4546问题,还可以使用优先队列(Priority Queue)来解决。以下是使用优先队列的解法思路: 1. 首先,将数组a进行排序,以便后续处理。 2. 创建一个优先队列(最小堆),用于存储组合之和的候选值。 3. 初始化优先队列,将初始情况(即前0个数的组合之和)加入队列。 4. 开始从1到n遍历数组a的元素,对于每个元素a[i],将当前队列中的所有候选值取出,分别加上a[i],然后再将加和的结果作为新的候选值加入队列。 5. 重复步骤4直到遍历完所有元素。 6. 当队列的大小超过k时,将队列中的最小值弹出。 7. 最后,队列中的所有候选值之和即为前k小的组合之和。 以下是使用优先队列解决HDU4546问题的代码示例: ```cpp #include <iostream> #include <vector> #include <queue> #include <functional> using namespace std; int main() { int n, k; cin >> n >> k; vector<int> a(n); for (int i = 0; i < n; i++) { cin >> a[i]; } sort(a.begin(), a.end()); // 对数组a进行排序 priority_queue<long long, vector<long long>, greater<long long>> pq; // 最小堆 pq.push(0); // 初始情况,前0个数的组合之和为0 for (int i = 0; i < n; i++) { long long num = pq.top(); // 取出当前队列中的最小值 pq.pop(); for (int j = i + 1; j <= n; j++) { pq.push(num + a[i]); // 将所有加和结果作为新的候选值加入队列 num += a[i]; } if (pq.size() > k) { pq.pop(); // 当队列大小超过k时,弹出最小值 } } long long sum = 0; while (!pq.empty()) { sum += pq.top(); // 求队列中所有候选值之和 pq.pop(); } cout << sum << endl; return 0; } ``` 使用优先队列的方法可以有效地找到前k小的组合之和,时间复杂度为O(nklog(k))。希望这个解法对你有所帮助!
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值