UVA11462 Age Sort【基数排序/桶排序/计数排序】

You are given the ages (in years) of all people of a country with at least 1 year of age. You know that no individual in that country lives for 100 or more years. Now, you are given a very simple task ofsorting all the ages in ascending order.

Input

There are multiple test cases in the input file. Each case starts with an integer n (0 < n ≤ 2000000), thetotal number of people. In the next line, there are n integers indicating the ages. Input is terminatedwith a case where n = 0. This case should not be processed.

Output

For each case, print a line with n space separated integers. These integers are the ages of that countrysorted in ascending order.

Warning: Input Data is pretty big (∼ 25 MB) so use faster IO.

Sample Input

5

3 4 2 1 5

5

2 3 2 3 1

0

Sample Output

1 2 3 4 5

1 2 2 3 3


问题链接UVA11462 Age Sort

问题简述:(略)

问题分析

  数据的数量虽然多,值的范围比较小,准备一些桶把这些数据放进去就好了。

程序说明

  需要注意输出格式的控制。

题记

  桶排序是一种非常奇妙的排序方法。

参考链接:(略)


AC的C语言程序如下:

/* UVA11462 Age Sort */

#include <stdio.h>
#include <string.h>

#define N 100

int count[N];

int main(void)
{
    int n, a, flag, i, j;

    while(~scanf("%d", &n) && n) {
        memset(count, 0, sizeof(count));

        while(n--) {
            scanf("%d", &a);

            count[a]++;
        }

        /* 输出结果 */
        flag = 0;
        for(i=1; i<N; i++) {
            for(j=1; j<=count[i]; j++) {
                if(flag)
                    putchar(' ');
                printf("%d", i);
                flag = 1;
            }
        }
        putchar('\n');
    }

    return 0;
}



  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 3
    评论
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值