POJ2246 HDU1082 ZOJ1094 UVA442 Matrix Chain Multiplication【模拟】

 

Matrix Chain Multiplication

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2607 Accepted: 1585

Description

Suppose you have to evaluate an expression like A*B*C*D*E where A,B,C,D and E are matrices. 
Since matrix multiplication is associative, the order in which multiplications are performed is arbitrary. However, the number of elementary multiplications needed strongly depends on the evaluation order you choose. 
For example, let A be a 50*10 matrix, B a 10*20 matrix and C a 20*5 matrix. 
There are two different strategies to compute A*B*C, namely (A*B)*C and A*(B*C). 
The first one takes 15000 elementary multiplications, but the second one only 3500. 

Your job is to write a program that determines the number of elementary multiplications needed for a given evaluation strategy. 

Input

Input consists of two parts: a list of matrices and a list of expressions. 
The first line of the input file contains one integer n (1 <= n <= 26), representing the number of matrices in the first part. The next n lines each contain one capital letter, specifying the name of the matrix, and two integers, specifying the number of rows and columns of the matrix. 
The second part of the input file strictly adheres to the following syntax (given in EBNF): 

SecondPart = Line { Line } 

Line       = Expression 

Expression = Matrix | "(" Expression Expression ")"

Matrix     = "A" | "B" | "C" | ... | "X" | "Y" | "Z"

Output

For each expression found in the second part of the input file, print one line containing the word "error" if evaluation of the expression leads to an error due to non-matching matrices. Otherwise print one line containing the number of elementary multiplications needed to evaluate the expression in the way specified by the parentheses.

Sample Input

9
A 50 10
B 10 20
C 20 5
D 30 35
E 35 15
F 15 5
G 5 10
H 10 20
I 20 25
A
B
C
(AA)
(AB)
(AC)
(A(BC))
((AB)C)
(((((DE)F)G)H)I)
(D(E(F(G(HI)))))
((D(EF))((GH)I))

Sample Output

0
0
0
error
10000
error
3500
15000
40500
47500
15125

Source

Ulm Local 1996

 

 

 

问题链接POJ2246 HDU1082 ZOJ1094 UVA442 Matrix Chain Multiplication

问题简述:(略)

问题分析

  占个位置,不解释。

程序说明:(略)

题记:(略)

参考链接:(略)

 

AC的C++语言程序如下:

/* POJ2246 HDU1082 ZOJ1094 UVA442 Matrix Chain Multiplication */

#include <iostream>
#include <map>
#include <stack>

using namespace std;

struct Node { int row, col; };

int main()
{
    int n;
    char name;
    map<char, Node> matrix;
    cin >> n;
    for(int i = 0; i < n; i++)
    {
        cin >> name;
        cin >> matrix[name].row >> matrix[name].col;
    }
    string exp;
    while(cin >> exp)
    {
        int i;
        int count = 0;
        stack<Node> array;
        for(i = 0; i < exp.size(); i++)
        {
            if(exp[i] == '(')  continue;
            if(exp[i] == ')')
            {
                Node b = array.top();
                array.pop();
                Node a = array.top();
                array.pop();
                if(a.col != b.row)
                {
                    cout << "error" << endl;
                    break;
                }
                count += a.row * b.row * b.col;
                Node tmp = {a.row, b.col};
                array.push(tmp);
            }
            else  array.push(matrix[exp[i]]);
        }
        if(i == exp.size())
            cout << count << endl;
    }
    return 0;
}

 

 

 

 

 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值