POJ2361 ZOJ1908 UVA10363 Tic Tac Toe【Ad Hoc】

509 篇文章 9 订阅
232 篇文章 0 订阅

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2385 Accepted: 903

Description

Tic Tac Toe is a child's game played on a 3 by 3 grid. One player, X, starts by placing an X at an unoccupied grid position. Then the other player, O, places an O at an unoccupied grid position. Play alternates between X and O until the grid is filled or one player's symbols occupy an entire line (vertical, horizontal, or diagonal) in the grid.  
We will denote the initial empty Tic Tac Toe grid with nine dots. Whenever X or O plays we fill in an X or an O in the appropriate position. The example below illustrates each grid configuration from the beginning to the end of a game in which X wins.  
...  X..  X.O  X.O  X.O  X.O  X.O  X.O

...  ...  ...  ...  .O.  .O.  OO.  OO.

...  ...  ...  ..X  ..X  X.X  X.X  XXX

Your job is to read a grid and to determine whether or not it could possibly be part of a valid Tic Tac Toe game. That is, is there a series of plays that can yield this grid somewhere between the start and end of the game?

Input

The first line of input contains N, the number of test cases. 4N-1 lines follow, specifying N grid configurations separated by empty lines.

Output

For each case print "yes" or "no" on a line by itself, indicating whether or not the configuration could be part of a Tic Tac Toe game.

Sample Input

2
X.O
OO.
XXX

O.X
XX.
OOO

Sample Output

yes
no

Source


问题链接POJ2361 ZOJ1908 UVA10363 Tic Tac Toe

问题简述

  Tic Tac Toe是一种儿童玩的游戏,在一个3×3的棋盘上进行。两个游戏玩家交替进行。一个玩家(“X”表示)先走棋,在未被占用的网格上放置X,另一个玩家(“O”表示),在未被占用的网格上放置O。

  读入棋盘状态,问该棋盘状态是否为有效,即经过一系列下棋能否达到该状态?

问题分析

  先通过统计棋盘上2种棋子数量进行判定。

  再通过输赢判定,最后得出结论。

程序说明:(略)

题记:(略)

参考链接:(略)


AC的C++语言程序如下:
/* POJ2361 ZOJ1908 UVA10363 Tic Tac Toe */

#include <iostream>
#include <stdio.h>

using namespace std;

const int N = 3;
char grid[N][N + 1];

bool judge(char c)
{
    int j;
    for(int i = 0; i < N; i++) {
        // 按行判定
        for(j = 0; j < N && grid[i][j] == c; j++);
        if(j == N)
                return true;
        // 按列判定
        for(j = 0; j < N && grid[j][i] == c; j++);
        if(j == N)
            return true;
    }

    // 按邪线判定
    for(j = 0; j < N && grid[j][j] == c; j++);
    if(j == N)
        return true;
    for(j = 0; j < N && grid[j][N - 1 - j] == c; j++);
    if(j == N)
        return true;

    return false;
}

int main()
{
    int n;
    scanf("%d", &n);
    getchar();
    while(n--) {
        scanf("%s%s%s", grid[0], grid[1], grid[2]);

        bool flag = true;
        int xcnt = 0, ocnt = 0;
        for(int i = 0; i < N; i++)
            for(int j = 0; j < N; j++)
                if(grid[i][j] == 'X')
                    xcnt++;
                else if(grid[i][j] == 'O')
                    ocnt++;

        if(xcnt < ocnt || xcnt - ocnt > 1)
            flag = false;
        else {
            if(judge('O') && ocnt != xcnt)
                flag = false;
            else if(judge('X') && xcnt - ocnt != 1)
                flag = false;
        }

        printf("%s\n", flag ? "yes" : "no");
    }

    return 0;
}





  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值