POJ1200 Crazy Search【哈希函数】

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 31418 Accepted: 8679

Description

Many people like to solve hard puzzles some of which may lead them to madness. One such puzzle could be finding a hidden prime number in a given text. Such number could be the number of different substrings of a given size that exist in the text. As you soon will discover, you really need the help of a computer and a good algorithm to solve such a puzzle.  
Your task is to write a program that given the size, N, of the substring, the number of different characters that may occur in the text, NC, and the text itself, determines the number of different substrings of size N that appear in the text.  

As an example, consider N=3, NC=4 and the text "daababac". The different substrings of size 3 that can be found in this text are: "daa"; "aab"; "aba"; "bab"; "bac". Therefore, the answer should be 5.  

Input

The first line of input consists of two numbers, N and NC, separated by exactly one space. This is followed by the text where the search takes place. You may assume that the maximum number of substrings formed by the possible set of characters does not exceed 16 Millions.

Output

The program should output just an integer corresponding to the number of different substrings of size N found in the given text.

Sample Input

3 4
daababac

Sample Output

5

Hint

Huge input,scanf is recommended.

Source


问题链接POJ1200 Crazy Search

问题简述:(略)

问题分析

  对于一个字符串,问其长度为n的字串有多少种?字符的种类不会超过nc种。

  将出现的字母映射为自然数0到n-1,n为出现的字母的数量。这样做的好处是算出来的哈希值(整数)比较小。

  使用nc作为计算哈希值时seed。

程序说明:(略)

题记:(略)

参考链接:(略)


AC的C++语言程序如下:
/* POJ1200 Crazy Search */

#include<iostream>
#include <string>
#include <cstring>

using namespace std;

const int N2 = 16e6;
bool hashval[N2 + 1];
char digit[26];

int main()
{
    int n, nc;
    string s;
    while(cin >> n >> nc >> s) {
        memset(hashval, 0, sizeof(hashval));
        memset(digit, 0, sizeof(digit));

        int k = 0;
        for(int i = 0; s[i]; i++)
            if(digit[s[i] - 'a'] == 0)
                digit[s[i] - 'a'] = k++;

        int len = s.size() - n + 1;
        int ans = len;
        for(int i=0; i < len; i++) {
            int hv = 0;
            for(int j = i; j < i + n; j++)
                hv = hv * nc + digit[s[j] - 'a'];
            hv %= N2;

            if(hashval[hv])
                ans--;
            else
                hashval[hv] = true;
        }

        cout << ans << endl;
    }

    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值