UVA11849 HDU3763 CD【合并有序序列】

708 篇文章 19 订阅
70 篇文章 2 订阅

Jack and Jill have decided to sell some of their Compact Discs, while they still have some value. They have decided to sell one of each of the CD titles that they both own. How many CDs can Jack and Jill sell?
    Neither Jack nor Jill owns more than one copy of each CD.
Input
The input consists of a sequence of test cases. The first line of each test case contains two non-negative integers N and M, each at most one million, specifying the number of CDs owned by Jack and by Jill, respectively. This line is followed by N lines listing the catalog numbers of the CDs owned by Jack in increasing order, and M more lines listing the catalog numbers of the CDs owned by Jill in increasing order. Each catalog number is a positive integer no greater than one billion. The input is terminated by a line containing two zeros. This last line is not a test case and should not be processed.
Output
For each test case, output a line containing one integer, the number of CDs that Jack and Jill both own.
Sample Input
3 3
1
2
3
1
2
4
0 0
Sample Output
2

问题链接UVA11849 HDU3763 CD
问题简述:(略)
问题分析
    给定2个有序序列,求2个序列的相同元素个数。
    合并2个有序序列即可,使用2个指针(下标)进行合并处理。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C++语言程序如下:

/* UVA11849 HDU3763 CD */

#include <bits/stdc++.h>

using namespace std;

const int N = 1e6;
int jack[N], jill[N];

int main()
{
    int n, m;
    while(~scanf("%d%d", &n, &m) && (n || m)) {
        for(int i = 0; i < n; i++)
            scanf("%d", &jack[i]);
        for(int i = 0; i < m; i++)
            scanf("%d", &jill[i]);

        int p = 0, q = 0, cnt = 0;
        while(p < n && q < m)
            if(jack[p] == jill[q]) cnt++, p++, q++;
            else if(jack[p] < jill[q]) p++;
            else /* if(jack[p] > jill[q]) */ q++;

        printf("%d\n", cnt);
    }

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值