UVA10339 ZOJ1839 Watching Watches【时间计算】

It has been said that a watch that is stopped keeps better time than one that loses 1 second per day. The one that is stopped reads the correct time twice a day while the one that loses 1 second per day is correct only once every 43,200 days. This maxim applies to old fashioned 12-hour analog watches, whose hands move continuously (most digital watches would display nothing at all if stopped).
    Given two such analog watches, both synchronized to midnight, that keep time at a constant rate but run slow by k and m seconds per day respectively, what time will the watches show when next they have exactly the same time?
Input
Input consists of a number of lines, each with two distinct non-negative integers k and m between 0 and 256, indicating the number of seconds per day that each watch loses.
Output
For each line of input, print k, m, and the time displayed on each watch, rounded to the nearest minute. Valid times range from 01:00 to 12:59.
Sample Input
1 2
0 7
Sample Output
1 2 12:00
0 7 10:17

问题链接UVA10339 ZOJ1839 Watching Watches
问题简述:(略)
问题分析
    两个时钟,一个每天慢k秒,一个每天慢m秒,问两钟重新相遇的时刻。
    1圈有12 * 60 * 60秒,1圈秒数 / abs(k - m)则可以求出多少天会相遇,就可以算出慢的时间数(秒单位),最后求该时刻的时和分。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C++语言程序如下:

/* UVA10339 ZOJ1839 Watching Watches */

#include <bits/stdc++.h>

using namespace std;

int main()
{
    int k, m;
    while(~scanf("%d%d", &k, &m)) {
        int d = abs(m - k);
        int min = (int)(12 * 60 * 1.0 / d * (24 * 60 * 60 - k) + 0.5) % (24 * 60);
        int h = min / 60;
        h %= 12;
        if(h == 0) h = 12;
        min %= 60;

        printf("%d %d %02d:%02d\n", k, m, h, min);
    }

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值