Curling 2.0 POJ - 3009

题目:

On Planet MM-21, after their Olympic games this year, curling is getting popular. But the rules are somewhat different from ours. The game is played on an ice game board on which a square mesh is marked. They use only a single stone. The purpose of the game is to lead the stone from the start to the goal with the minimum number of moves.

Fig. 1 shows an example of a game board. Some squares may be occupied with blocks. There are two special squares namely the start and the goal, which are not occupied with blocks. (These two squares are distinct.) Once the stone begins to move, it will proceed until it hits a block. In order to bring the stone to the goal, you may have to stop the stone by hitting it against a block, and throw again.


Fig. 1: Example of board (S: start, G: goal)

The movement of the stone obeys the following rules:

  • At the beginning, the stone stands still at the start square.
  • The movements of the stone are restricted to x and y directions. Diagonal moves are prohibited.
  • When the stone stands still, you can make it moving by throwing it. You may throw it to any direction unless it is blocked immediately(Fig. 2(a)).
  • Once thrown, the stone keeps moving to the same direction until one of the following occurs:
    • The stone hits a block (Fig. 2(b), (c)).
      • The stone stops at the square next to the block it hit.
      • The block disappears.
    • The stone gets out of the board.
      • The game ends in failure.
    • The stone reaches the goal square.
      • The stone stops there and the game ends in success.
  • You cannot throw the stone more than 10 times in a game. If the stone does not reach the goal in 10 moves, the game ends in failure.


Fig. 2: Stone movements

Under the rules, we would like to know whether the stone at the start can reach the goal and, if yes, the minimum number of moves required.

With the initial configuration shown in Fig. 1, 4 moves are required to bring the stone from the start to the goal. The route is shown in Fig. 3(a). Notice when the stone reaches the goal, the board configuration has changed as in Fig. 3(b).


Fig. 3: The solution for Fig. D-1 and the final board configuration

Input

The input is a sequence of datasets. The end of the input is indicated by a line containing two zeros separated by a space. The number of datasets never exceeds 100.

Each dataset is formatted as follows.

the width(=w) and the height(=h) of the board 
First row of the board 
... 
h-th row of the board

The width and the height of the board satisfy: 2 <= w <= 20, 1 <= h <= 20.

Each line consists of w decimal numbers delimited by a space. The number describes the status of the corresponding square.

0vacant square
1block
2start position
3goal position

The dataset for Fig. D-1 is as follows:

6 6 
1 0 0 2 1 0 
1 1 0 0 0 0 
0 0 0 0 0 3 
0 0 0 0 0 0 
1 0 0 0 0 1 
0 1 1 1 1 1

Output

For each dataset, print a line having a decimal integer indicating the minimum number of moves along a route from the start to the goal. If there are no such routes, print -1 instead. Each line should not have any character other than this number.

Sample Input

2 1
3 2
6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1
6 1
1 1 2 1 1 3
6 1
1 0 2 1 1 3
12 1
2 0 1 1 1 1 1 1 1 1 1 3
13 1
2 0 1 1 1 1 1 1 1 1 1 1 3
0 0

Sample Output

1
4
-1
4
10
-1

题意:

给你两个数字n,m,代表图度的大小是m*n(注意,和平时的习惯不同);

当两个数字都为0 时,输入停止;

下面是一个地图:0代表 可以行走的位置,1代表障碍物,2代表起点,3代表是终点;

冰壶每一次只能像一个方向运动,只有碰到障碍物才会停止,并且会把障碍物撞碎(会停在障碍物的前面);

题目要求在10步之内要出来结果,否则就是无法到达;

让你求出来冰壶到达终点的最小步数;

思路:

在搜索的过程中,因为碰到障碍物才能停止,不用循环,直接在现在的位置上前进一格就可以了,题目中的步数并不是行走的格数;

代码如下:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

const int N=30;

int n,m;
int map[N][N];
int ex,ey,sx,sy;
int minn;
int nextt[4][2]= {{1,0},{-1,0},{0,1},{0,-1}};

void DFS(int x,int y,int step)
{
    if(step>10||step>minn)//超出10步或者是已经比已知的步数大,直接就减枝;
        return ;
    for(int i=0; i<4; i++)
    {
        int nx=x+nextt[i][0];
        int ny=y+nextt[i][1];
        if(nx<0||nx>=m||ny<0||ny>=n)//出界;
            continue;
        if(map[nx][ny]==1)//碰到了block;
            continue;
        while(!map[nx][ny]&&(nx>=0&&nx<m&&ny>=0&&ny<n))
        {//只有碰到了障碍物才会停止,否则一直向前;
            nx=nx+nextt[i][0];
            ny=ny+nextt[i][1];
        }
        if(nx>=0&&nx<m&&ny>=0&&ny<n)//停止时因为碰到了block,不是因为出界;
        {
            if(nx==ex&&ny==ey)//到达终点;
            {
                if(step<minn)//变更最小步数;
                    minn=step;
            }
            else//没有到达终点;
            {
                map[nx][ny]=0;//障碍物被撞碎了;
                DFS(nx-nextt[i][0],ny-nextt[i][1],step+1);
                //记得碰到障碍物会停止,但是不会在障碍物的位置上停止,
                //因为在障碍物的前面一个位置,所以现在冰壶的位置应该向后退一步;
                map[nx][ny]=1;//复原;
            }
        }
    }
    return ;
}

int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        if(n==0&&m==0)
            break;
        for(int i=0; i<m; i++)
        {
            for(int j=0; j<n; j++)
            {
                scanf("%d",&map[i][j]);
                if(map[i][j]==2)
                {
                    sx=i;//起点;
                    sy=j;
                    map[i][j]=0;//冰壶被推走后,原来的位置应该是空的;
                }
                else if(map[i][j]==3)
                {
                    ex=i;//终点;
                    ey=j;
                }
            }
        }
        minn=11;//最大步数是10,极大值可以设置为11;
        DFS(sx,sy,1);
        if(minn==11)
            printf("-1\n");
        else
            printf("%d\n",minn);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
项目:使用AngularJs编写的简单 益智游戏(附源代码)  这是一个简单的 javascript 项目。这是一个拼图游戏,也包含一个填字游戏。这个游戏玩起来很棒。有两个不同的版本可以玩这个游戏。你也可以玩填字游戏。 关于游戏 这款游戏的玩法很简单。如上所述,它包含拼图和填字游戏。您可以通过移动图像来玩滑动拼图。您还可以选择要在滑动面板中拥有的列数和网格数。 另一个是填字游戏。在这里你只需要找到浏览器左侧提到的那些单词。 要运行此游戏,您需要在系统上安装浏览器。下载并在代码编辑器中打开此项目。然后有一个 index.html 文件可供您修改。在命令提示符中运行该文件,或者您可以直接运行索引文件。使用 Google Chrome 或 FireFox 可获得更好的用户体验。此外,这是一款多人游戏,双方玩家都是人类。 这个游戏包含很多 JavaScript 验证。这个游戏很有趣,如果你能用一点 CSS 修改它,那就更好了。 总的来说,这个项目使用了很多 javascript 和 javascript 库。如果你可以添加一些具有不同颜色选项的级别,那么你一定可以利用其库来提高你的 javascript 技能。 演示: 该项目为国外大神项目,可以作为毕业设计的项目,也可以作为大作业项目,不用担心代码重复,设计重复等,如果需要对项目进行修改,需要具备一定基础知识。 注意:如果装有360等杀毒软件,可能会出现误报的情况,源码本身并无病毒,使用源码时可以关闭360,或者添加信任。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值