(甲)1005 Spell It Right (20 分)

题目:

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (≤10​^100​​).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

12345

Sample Output:

one five

题意:

给你一个数字,数字大小范围为 10^100,让你求出来该数字的各位数字的总和,然后用英文数字按位输出结果;

思路:

因为数字太大,所以要用字符串来存储数字,计算出来该数字的各位数字之和后用英文输出就可以了,注意输出的格式要求:每两个数字之间有一个空格。

代码如下:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

char a[110];
int b[110];
int sum;
int s;
char q[11][10]= {"zero","one","two","three","four","five","six","seven","eight","nine"};

int main()
{
    while(~scanf("%s",a))
    {
        int l=strlen(a);
        sum=0,s=0;
        for(int i=0; i<l; i++)
        {
            sum+=a[i]-'0';
        }
        int flag=0;
        if(sum==0)//结果为0时进不去while循环,否则第2组测试数据错误。。。。
            printf("zero\n");
        else
        {
            while(sum!=0)
            {
                int k=sum%10;
                sum=sum/10;
                b[s++]=k;//存储结果的每一位上的数字;
            }
            for(int i=s-1; i>=0; i--)//注意输出格式;
            {
                if(flag==0)
                {
                    printf("%s",q[b[i]]);
                    flag=1;
                }
                else
                    printf(" %s",q[b[i]]);
            }
            printf("\n");
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值