POJ 3280 Cheapest Palindrome (区间DP)

Description

Keeping track of all the cows can be a tricky task so Farmer John has installed a system to automate it. He has installed on each cow an electronic ID tag that the system will read as the cows pass by a scanner. Each ID tag's contents are currently a single string with length M (1 ≤ M ≤ 2,000) characters drawn from an alphabet of N (1 ≤ N ≤ 26) different symbols (namely, the lower-case roman alphabet).

Cows, being the mischievous creatures they are, sometimes try to spoof the system by walking backwards. While a cow whose ID is "abcba" would read the same no matter which direction the she walks, a cow with the ID "abcb" can potentially register as two different IDs ("abcb" and "bcba").

FJ would like to change the cows's ID tags so they read the same no matter which direction the cow walks by. For example, "abcb" can be changed by adding "a" at the end to form "abcba" so that the ID is palindromic (reads the same forwards and backwards). Some other ways to change the ID to be palindromic are include adding the three letters "bcb" to the begining to yield the ID "bcbabcb" or removing the letter "a" to yield the ID "bcb". One can add or remove characters at any location in the string yielding a string longer or shorter than the original string.

Unfortunately as the ID tags are electronic, each character insertion or deletion has a cost (0 ≤ cost ≤ 10,000) which varies depending on exactly which character value to be added or deleted. Given the content of a cow's ID tag and the cost of inserting or deleting each of the alphabet's characters, find the minimum cost to change the ID tag so it satisfies FJ's requirements. An empty ID tag is considered to satisfy the requirements of reading the same forward and backward. Only letters with associated costs can be added to a string.

Input

Line 1: Two space-separated integers:  N and  M 
Line 2: This line contains exactly  M characters which constitute the initial ID string 
Lines 3.. N+2: Each line contains three space-separated entities: a character of the input alphabet and two integers which are respectively the cost of adding and deleting that character.

Output

Line 1: A single line with a single integer that is the minimum cost to change the given name tag.

Sample Input

3 4
abcb
a 1000 1100
b 350 700
c 200 800

Sample Output

900

Hint

If we insert an "a" on the end to get "abcba", the cost would be 1000. If we delete the "a" on the beginning to get "bcb", the cost would be 1100. If we insert "bcb" at the begining of the string, the cost would be 350 + 200 + 350 = 900, which is the minimum.

Source


题目链接:Cheapest Palindrome

题意:

长度为M的字符串含有N个字母(小写字母),给出每个字母的删除和添加操作的花费,

求将字符串变成回文串的最小花费

其中合法操作是在字符串任意位置添加字母或者将任意字母删除

至于你说能不能全部删除变成空串,个人觉得删到只有一个字母的时候就是回文串了

删成空串将花费更多

分析:

dp[i][j]表示将区间[i,j]变成回文串的最小代价
从3个子状态考虑:
1.安排第i个字符 :dp[i][j] = dp[i+1][j] + min(add[i],del[i])
2.安排第j个字符 :dp[i][j] = dp[i][j-1] + min(add[j],del[j])
3.若s[i] == s[j] :dp[i][j] = dp[i+1][j-1]
会不会有更优的子状态?
比如安排第i个字符的时候可以利用到区间[i+1,j]里面于s[i]相等的字符s[k]
然后获得更小的值?
首先这样做是错的,因为区间[i+1,j]的字符已经是改变过的
再改变的时候根本不知道字符s[k]是不是还存在(它可能已经被删除了)
其次 ,这样做是没有必要的,区间DP不会错过任何一个区间
所以考虑s[i] == s[k]的情况其实是在做区间[i,k]的时候做好了
所以真正需要判断的只是上述3个子状态 

#define mem(a,x) memset(a,x,sizeof(a))
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
#include<set>
#include<stack>
#include<cmath>
#include<map>
#include<stdlib.h>
#include<cctype>
#include<string>
#define Sint(n) scanf("%d",&n)
#define Sll(n) scanf("%I64d",&n)
#define Schar(n) scanf("%c",&n)
#define Sint2(x,y) scanf("%d %d",&x,&y)
#define Sll2(x,y) scanf("%I64d %I64d",&x,&y)
#define Pint(x) printf("%d",x)
#define Pllc(x,c) printf("%I64d%c",x,c)
#define Pintc(x,c) printf("%d%c",x,c)
using namespace std;
typedef long long ll;
const int N = 27;
const int M = 2007;
int dp[M][M];
int add[N],del[N]; 
char s[M];
int DP(int i ,int j)
{
	if (i>=j) return 0;
	if (~dp[i][j]) return dp[i][j];
	dp[i][j] = DP(i+1,j) + min(add['a'-s[i]],del['a'-s[i]]);
	dp[i][j] = min(dp[i][j],DP(i,j-1)+min(add['a'-s[j]],del['a'-s[j]])) ;
	if (s[i] == s[j]) dp[i][j] = min(dp[i][j],DP(i+1,j-1));
	return dp[i][j];
}
int main()
{
    int n,m;
    while (Sint2(n,m) == 2)
    {
    	scanf("%s",s);
//    	getchar();
    	for (int i = 1;i <= n;++i)
    	{
    		char c[7];scanf("%s",c);
    		Sint2(add['a'-c[0]],del['a'-c[0]]);
//    		getchar();
		}
		mem(dp,-1);
		Pintc(DP(0,m-1),'\n');
	}
    return 0;
}
/*
1 1
a
a 100 200
*/


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值