Problem Description
FJ is surveying his herd to find the most average cow. He wants to know how much milk this 'median' cow gives: half of the cows give as much or more than the median; half give as much or less.
Given an odd number of cows N (1 <= N < 10,000) and their milk output (1..1,000,000), find the median amount of milk given such that at least half the cows give the same amount of milk or more and at least half give the same or less.
Given an odd number of cows N (1 <= N < 10,000) and their milk output (1..1,000,000), find the median amount of milk given such that at least half the cows give the same amount of milk or more and at least half give the same or less.
Input
* Line 1: A single integer N <br> <br>* Lines 2..N+1: Each line contains a single integer that is the milk output of one cow.
Output
* Line 1: A single integer that is the median milk output.
Sample Input
5 2 4 1 3 5
Sample Output
3
题目要求:求出生产牛奶的中位数。
思路:直接排序输出第(n-1)/2个元素即可。
细节:没什么主意的,签到题。
#include<cstdio>
#include<vector>
#include<algorithm>
using namespace std;
int main()
{
vector<int> a;
int n, i, m;
scanf("%d", &n);
for (i = 0;i < n;i++)
{
scanf("%d", &m);
a.push_back(m);
}
sort(a.begin(),a.end());
printf("%d\n", a[( n - 1) / 2]);
}