1004 of dp

Problem D

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 89   Accepted Submission(s) : 29
Problem Description
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers. <br><br>Write a program to find and print the nth element in this sequence<br>
 

Input
The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.<br>
 

Output
For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.<br>
 

Sample Input
  
  
1 2 3 4 11 12 13 21 22 23 100 1000 5842 0
 
Sample Output
   
   
The 1st humble number is 1. The 2nd humble number is 2. The 3rd humble number is 3. The 4th humble number is 4. The 11th humble number is 12. The 12th humble number is 14. The 13th humble number is 15. The 21st humble number is 28. The 22nd humble number is 30. The 23rd humble number is 32. The 100th humble number is 450. The 1000th humble number is 385875. The 5842nd humble number is 2000000000.
 
题目要求:求出只含有2 3 5 7质因子的第n个数。
解题思路:因为每个数只含有2 3  5 7,所以第n个数是前面某项的 2 3 5 7倍,又因为是升序排列,
所以定义4个指针本别代表是否算过第i项的2 3 5 7倍,若算过指针+1,即
ans=min(2*a[b[1]],3*a[b[2]],5*a[b[3]],7*a[b[4]]);
        a[i]=ans;
        if(ans==2*a[b[1]])b[1]++;
        if(ans==3*a[b[2]])b[2]++;
        if(ans==5*a[b[3]])b[3]++;
        if(ans==7*a[b[4]])b[4]++;
一直循环到第5842项即可。
解题代码:
#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
#include<string.h>
using namespace std;
int min(int a,int b,int c,int d)
{
    int min1=a<b?a:b;
    int min2=c<d?c:d;
    return min1<min2?min1:min2;
}
int a[6000];
int main()
{
    int flag[5]={0},p;
    int i,j;
    a[1]=1;int ans;int b[5];
    for(i=1;i<=4;i++)b[i]=1;
    for(i=2;i<=5842;i++)
    {
         ans=min(2*a[b[1]],3*a[b[2]],5*a[b[3]],7*a[b[4]]);
        a[i]=ans;
        if(ans==2*a[b[1]])b[1]++;
        if(ans==3*a[b[2]])b[2]++;
        if(ans==5*a[b[3]])b[3]++;
        if(ans==7*a[b[4]])b[4]++;

    }
    int n;
    while(cin>>n&&n)
    {
        cout<<"The "<<n;
        if(n%10==1&&n%100!=11)cout<<"st";
        else if(n%10==2&&n%100!=12)cout<<"nd";
        else if(n%10==3&&n%100!=13)cout<<"rd";
        else cout<<"th";
        cout<<" humble number is "<<a[n]<<"."<<endl;
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值