【HDU 1005】Number Sequence —— 找周期

14 篇文章 0 订阅

原题链接


Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 122213    Accepted Submission(s): 29653


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
  
  
1 1 3 1 2 10 0 0 0
 

Sample Output
  
  
2 5




解题报告:

一开始做这题就是想暴力求解,所以如期的TLE了。然后换个思路,直接算出了通项公式,但是通项公式有两项都是带根号的,最后不能很好的转换为int,放弃!再接着,瞥了下discuss里面的讨论,得到的关键字是周期,其实也很容易想到,毕竟是mod 7,很快就应该有周期,所以只需要找到周期就好。注意!!!但是由于f(1)=f(2)=1是初始项,并不一定满足通项的结构,所以应该从f(3)开始匹配找周期!更详细的解释请移步:[ACM_HDU_1005]Number Sequence

当然,这题还有另外的解法,详见 【HDU1005】Number Sequence(矩阵乘法)



#include <iostream>
using namespace std;
int a,b,n;
int A[100];
int main()
{
    while(cin>>a>>b>>n){
        if(!a && !b && !n) break;
        if(n==1 || n==2) cout<<1<<endl;
        else{
            A[1]=A[2]=1;int cyc=n;
            for(int i=3;i<=100;++i){
                A[i]=(a*A[i-1]+b*A[i-2])%7;
                if(i>5 &&  A[i]==A[4] && A[i-1]==A[3]){cyc=i-4;break;}
            }

            //输出
            cout<<A[(n-3)%cyc+3]<<endl;
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值