PAT (Advanced Level) 1075. PAT Judge (25) PAT排名 结构体排序

The ranklist of PAT is generated from the status list, which shows the scores of the submittions. This time you are supposed to generate the ranklist for PAT.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive integers, N (<=104), the total number of users, K (<=5), the total number of problems, and M (<=105), the total number of submittions. It is then assumed that the user id's are 5-digit numbers from 00001 to N, and the problem id's are from 1 to K. The next line contains K positive integers p[i] (i=1, ..., K), where p[i] corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submittion in the following format:

user_id problem_id partial_score_obtained

where partial_score_obtained is either -1 if the submittion cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

Output Specification:

For each test case, you are supposed to output the ranklist in the following format:

rank user_id total_score s[1] ... s[K]

where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then "-" must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.

The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id's. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

Sample Input:
7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0
Sample Output:
1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -
记录每个学生的id,总分,每道题的分数,满分通过的题数,是否曾经通过编译器(从未通过的不进入排行榜)。对于一道题的分数,用-2表示未提交过,-1表示没通过编译器。根据每一行的输入,更新相应学生该题分数和总分。全部输入完之后进行结构体排序。最后输出所有曾经通过编译器的同学的信息,输出每一道题分数时,-2对应'-',-1对应'0'。
/*2015.7.29cyq*/
#include <iostream>
#include <vector>
#include <algorithm>
#include <fstream>
using namespace std;

//ifstream fin("case1.txt");
//#define cin fin

int N,K,M;

struct stu{
	int id;
	int totalScore;
	vector<int> scores;//scores[i]表示题i的得分
	int pass;//满分通过的题数  
	bool havePassCompiler;//曾经通过编译器,能进入排行榜  
	stu():id(0),totalScore(0),pass(0),havePassCompiler(false){
		for(int i=0;i<=K;i++)
			scores.push_back(-2);//-2表示该题没有提交过
	}
};
bool cmp(const stu &a,const stu &b){//总分降序、通过题数降序、id升序  
	if(a.totalScore>b.totalScore)
		return true;
	if(a.totalScore==b.totalScore){
		if(a.havePassCompiler&&!b.havePassCompiler)
			return true;//考虑到平分的可能0分最多,先判断  
		else if(a.pass>b.pass)
			return true;
		else if(a.pass==b.pass)
			return a.id<b.id;
	}
	return false;
}
int main(){
	cin>>N>>K>>M;
	vector<int> fullScore(K+1);
	for(int i=1;i<=K;i++)
		cin>>fullScore[i];

	vector<stu> students(N+1);
	int a,b,c;
	while(M--){
		cin>>a>>b>>c;
		students[a].id=a;
		if(students[a].scores[b]<c){
			if(c>=0){
				if(!students[a].havePassCompiler)
					students[a].havePassCompiler=true;
				if(c>0){//更新总分 
					int tmp=students[a].scores[b];//原有分数
					if(tmp<=0)
						students[a].totalScore+=c;
					else
						students[a].totalScore=students[a].totalScore-tmp+c; 
				}
			}
			students[a].scores[b]=c;//更新该题得分 
			if(fullScore[b]==c)
				students[a].pass++;//满分题数加1  
		}
	}
	sort(students.begin()+1,students.end(),cmp);
	
	int rank=0;//排名,可能并列  
	for(int i=1;i<=N;i++){
		if(!students[i].havePassCompiler)//后续同学全是从未通过编译器的  
			break;
		if(rank==0||students[i].totalScore!=students[i-1].totalScore)
			rank=i;
		printf("%d %05d %d",rank,students[i].id,students[i].totalScore);
		for(int j=1;j<=K;j++){
			if(students[i].scores[j]==-2)
				printf(" -");
			else if(students[i].scores[j]==-1)
				printf(" 0");
			else
				printf(" %d",students[i].scores[j]);
		}
		printf("\n");
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值