poj 1942 Paths on a Grid

题目链接:点击打开链接

Description

Imagine you are attending your math lesson at school. Once again, you are bored because your teacher tells things that you already mastered years ago (this time he's explaining that (a+b)2=a2+2ab+b2). So you decide to waste your time with drawing modern art instead. 

Fortunately you have a piece of squared paper and you choose a rectangle of size n*m on the paper. Let's call this rectangle together with the lines it contains a grid. Starting at the lower left corner of the grid, you move your pencil to the upper right corner, taking care that it stays on the lines and moves only to the right or up. The result is shown on the left: 

Really a masterpiece, isn't it? Repeating the procedure one more time, you arrive with the picture shown on the right. Now you wonder: how many different works of art can you produce?

Input

The input contains several testcases. Each is specified by two unsigned 32-bit integers n and m, denoting the size of the rectangle. As you can observe, the number of lines of the corresponding grid is one more in each dimension. Input is terminated by n=m=0.

Output

For each test case output on a line the number of different art works that can be generated using the procedure described above. That is, how many paths are there on a grid where each step of the path consists of moving one unit to the right or one unit up? You may safely assume that this number fits into a 32-bit unsigned integer.

Sample Input

5 4
1 1
0 0

Sample Output

126
2
题目大意:给出一个方格矩阵的长和宽,计算从左下角到右上角有几种走法,只能向上和右走,

基本思路:这个题让我想起了马踏过河卒的那个题,很类似,就是除了左边界和下边界,每个点都有来自左边的步数和下边的步数,相加就是该点的步数,可是显然这样会超时

这个题在组合数学里面,用组合公求解的,可是用两个for同样超时,看了discuss后,有说只能按照长和宽最小的那个进行循环,因为组合公式可以化简,

公式:C(n+m)!,(n!m!)

<span style="font-size:18px;">#include <iostream>
#include<cstdio>
#include<cstring>

using namespace std;
///暴力超时的代码
/*long long  a[100000],b[100000];
int main()
{
    int n,m;
    while(cin>>n>>m)
    {
        if(n==0&&m==0)break;
        if(n==0||m==0)
        {
            cout<<"0\n";
            continue;
        }
        memset(a,0,sizeof(0));
        for(int i=1;i<=n;i++)
        {
            a[i]=1;
        }
        for(int i=1;i<=n;i++)
        {
            b[0]=1;
            for(int j=1;j<=m;j++)
            {
               b[j]=b[j-1]+a[j];
               a[j]=b[j];
            }
        }
        cout<<b[m]<<endl;
    }
    return 0;
}*/
int main()
{
    double n,m;
    while(~scanf("%lf%lf",&n,&m))
    {
        if(n==0&&m==0)break;
        /*if(n==0||m==0)
        {
            printf("1\n");
            continue;
        }*/
        double sn,sm,smn;
        sn=sm=smn=1;
        if(n<m)///取最小的循环
        {
            for(double i=1,k=m+n;i<=n;i++,k--)
            {
                sn=sn*i;
                smn=smn*k;
            }
            smn=smn/sn;
             printf("%.0lf\n",smn);
        }
       else
        {
            for(double i=1,k=m+n;i<=m;i++,k--)
            {
                sm=sm*i;
                smn=smn*k;
            }
             smn=smn/sm;
             printf("%.0lf\n",smn);
        }
    }
    return 0;
}
</span>


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值