POJ2777——Count Color(线段树)

Count Color
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 33637 Accepted: 10153

Description

Chosen Problem Solving and Program design as an optional course, you are required to solve all kinds of problems. Here, we get a new problem. 

There is a very long board with length L centimeter, L is a positive integer, so we can evenly divide the board into L segments, and they are labeled by 1, 2, ... L from left to right, each is 1 centimeter long. Now we have to color the board - one segment with only one color. We can do following two operations on the board: 

1. "C A B C" Color the board from segment A to segment B with color C. 
2. "P A B" Output the number of different colors painted between segment A and segment B (including). 

In our daily life, we have very few words to describe a color (red, green, blue, yellow…), so you may assume that the total number of different colors T is very small. To make it simple, we express the names of colors as color 1, color 2, ... color T. At the beginning, the board was painted in color 1. Now the rest of problem is left to your. 

Input

First line of input contains L (1 <= L <= 100000), T (1 <= T <= 30) and O (1 <= O <= 100000). Here O denotes the number of operations. Following O lines, each contains "C A B C" or "P A B" (here A, B, C are integers, and A may be larger than B) as an operation defined previously.

Output

Ouput results of the output operation in order, each line contains a number.

Sample Input

2 2 4
C 1 1 2
P 1 2
C 2 2 2
P 1 2

Sample Output

2
1

第一道线段树题目,未完待续……有空再写

#include <algorithm>
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#define INF 0x7fffffff
#define MAX 100000
using namespace std;
struct SegTree
{
    int left,right,color;
}tree[MAX*4];
bool vis[50];
int sum=0;
void Build(int left,int right,int k)   // [l,mid],[mid+1,r] 只含整数点
{
    tree[k].left=left;
    tree[k].right=right;
    tree[k].color=1;
    if(left==right) return;

    int mid=(left+right)/2;
    Build(left,mid,k*2);
    Build(mid+1,right,k*2+1);
}
void Insert(int st,int ed,int color,int k)   //插入线段
{
    if(tree[k].left==st&&tree[k].right==ed)  // 如果区间符合,涂色,返回
    {
        tree[k].color=color;
        return ;
    }
    if(tree[k].color)  // 标记下移
    {
        tree[k*2].color=tree[k].color;
        tree[k*2+1].color=tree[k].color;
        tree[k].color=0;
    }
    int mid = (tree[k].left+tree[k].right)/2 ;  //找到中间值
    //判断插入线段位置
    if(mid>=ed)                       //插入左子树
        Insert(st,ed,color,k*2);
    else if(mid<st)                   //插入右子树
        Insert(st,ed,color,k*2+1);
    else                              //分段,插入左右子树
    {
        Insert(st,mid,color,k*2);
        Insert(mid+1,ed,color,k*2+1);
    }
}
void Query(int st,int ed,int k)   //询问操作
{
    if(tree[k].color)
    {
        if(!vis[tree[k].color])
        {
            vis[tree[k].color]=1;
            sum++;
        }
        return ;
    }
    int mid=(tree[k].left+tree[k].right)/2;
    if(mid>=ed)
        Query(st,ed,k*2);
    else if(mid<st)
        Query(st,ed,k*2+1);
    else
    {
        Query(st,mid,k*2);
        Query(mid+1,ed,k*2+1);
    }
}
int main()
{
    int n,m,c;
    char q[3];
    int l,r,cl;
    cin>>n>>m>>c;
    Build(1,n,1);
    while(c--)
    {
        scanf("%s",q);
        if(q[0]=='C')
        {
            scanf("%d%d%d",&l,&r,&cl);
            if(l>r) swap(l,r);
            Insert(l,r,cl,1);
        }
        else if(q[0]=='P')
        {
            sum=0;
            scanf("%d%d",&l,&r);
            if(l>r) swap(l,r);
            memset(vis,0,sizeof(vis));
            Query(l,r,1);
            cout<<sum<<endl;
        }
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值