POJ 3278 Catch That Cow

poj 3278 题目链接:http://poj.org/problem?id=3278

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a pointN (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 orX + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

解题思路:简单的bfs,注意要剪枝,注意题目的限定条件。
#include <iostream>
#include <cstring>
#include <queue>
using namespace std;

int n, k, a[100010], vis[100010];
queue<int> q;

int bfs()
{
	q.push(n);
	a[n] = 0;
	vis[n] = 1;

	while(!q.empty())
	{
		int tmp = q.front(), t;
		q.pop();

		for(int i = 0; i < 3; i++)
		{
			switch(i)
			{
			case 0: t = tmp - 1; break;
			case 1: t = tmp + 1; break;
			case 2: t = tmp * 2; break;
			}
			//注意这个地方不能写 t<=k,不然会wa,因为可能是先超过k,再减小达到k
			if(t >= 0 && t <= 100010 && !vis[t])
			{
				vis[t] = 1;
				q.push(t);
				a[t] = a[tmp] + 1;
			}
			if(t == k) return a[k];
		}
	}
	return -1;
}

int main()
{
	while(cin >> n >> k)
	{	
		memset(a,  0, sizeof(a));
		memset(vis, 0, sizeof(vis));
		if(n >= k) cout << n - k << endl;
		else
		{
			cout << bfs() <<endl;
			while(!q.empty())
			{
				q.pop();
			}
		}
	}

	return 0;
}
我之前wa了好几次,都是因为代码注释部分写的是t<=k,考虑的不全面。。。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值