最长公共子序列问题-HD1423

Greatest Common Increasing Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6073    Accepted Submission(s): 1976


Problem Description
This is a problem from ZOJ 2432.To make it easyer,you just need output the length of the subsequence.
 

Input
Each sequence is described with M - its length (1 <= M <= 500) and M integer numbers Ai (-2^31 <= Ai < 2^31) - the sequence itself.
 

Output
output print L - the length of the greatest common increasing subsequence of both sequences.
 

Sample Input
  
  
1 5 1 4 2 5 -12 4 -12 1 2 4
 

Sample Output

2

题目大意:求出两个数组公共的最长的上升子序列(可以不是连续的子序列)。

这是一道典型的求最长公共子序列问题。

#include <stdio.h>  
#include <string.h>  
  
#define MAX 501  
  
int T;  
int seq1[MAX], seq2[MAX];  
int len1, len2;  
int dp[MAX];  
  
int LCIS(){  
    int i, j;  
    int Max;  
    memset(dp, 0, sizeof(dp)); 

	//关键部分 
    for (i = 1; i <= len1; ++i){  
        Max = 0;  
        for (j = 1; j <= len2; ++j){  
            if (seq1[i] > seq2[j] && Max < dp[j])  
                Max = dp[j];  
            if (seq1[i] == seq2[j])  
                dp[j] = Max + 1;  
        }  
        
        /*观察该数组值的变化 
		for (int I = 1; I <= len2; ++I)
        printf("%d ",dp[I]);
        printf("\n");
		*/
    }  
	
    Max = 0;  
    for (i = 1; i <= len2; ++i){  
        if (Max < dp[i])  
            Max = dp[i];  
    }  
    return Max;  
}  
  
int main(){  
    int i;  
    scanf("%d", &T);  
    while (T-- != 0){  
        scanf("%d", &len1);  
        for (i = 1; i <= len1; ++i)  
            scanf("%d", &seq1[i]);  
        scanf("%d", &len2);  
        for (i = 1; i <= len2; ++i)  
            scanf("%d", &seq2[i]);  
		
        printf("%d\n", LCIS());  
        if (T)  
            putchar('\n');  
    }  
  
    return 0;  
}  
本题dp数组值的变化情况:

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值