poj 2480 Longge's problem(欧拉函数的性质)

Longge's problem
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6433 Accepted: 2064

Description

Longge is good at mathematics and he likes to think about hard mathematical problems which will be solved by some graceful algorithms. Now a problem comes: Given an integer N(1 < N < 2^31),you are to calculate ∑gcd(i, N) 1<=i <=N.

"Oh, I know, I know!" Longge shouts! But do you know? Please solve it.

Input

Input contain several test case.
A number N per line.

Output

For each N, output ,∑gcd(i, N) 1<=i <=N, a line

Sample Input

2
6

Sample Output

3
15

Source

POJ Contest,Author:Mathematica@ZSU

题意:求 ∑gcd(i, N) 1<=i <=N
题解:涉及欧拉函数,积极函数,莫比乌斯反演等...本弱菜无法说明,搞了很久,但是代码非常短的说.....这大概就是典型的数论题的特征吧....

#include<stdio.h>
int main()
{
    long long n,temp,res,i,cou;

    while(scanf("%I64d",&n)>0)
    {
        for(res=1,i=2;i*i<=n;i++)
        {
            if(n%i!=0) continue;
            cou=0;  temp=1;
            while(n%i==0){ n/=i; temp*=i; cou++; }
            res*=temp/i*(i-1)*cou+temp;
        }
        if(n>1) res*=2*n-1;
        printf("%I64d\n",res);
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值