poj 3071 Football(概率dp)

Football
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2423 Accepted: 1224

Description

Consider a single-elimination football tournament involving 2n teams, denoted 1, 2, …, 2n. In each round of the tournament, all teams still in the tournament are placed in a list in order of increasing index. Then, the first team in the list plays the second team, the third team plays the fourth team, etc. The winners of these matches advance to the next round, and the losers are eliminated. After n rounds, only one team remains undefeated; this team is declared the winner.

Given a matrix P = [pij] such that pij is the probability that team i will beat team j in a match determine which team is most likely to win the tournament.

Input

The input test file will contain multiple test cases. Each test case will begin with a single line containing n (1 ≤ n ≤ 7). The next 2n lines each contain 2n values; here, the jth value on the ith line represents pij. The matrix P will satisfy the constraints that pij = 1.0 − pji for all i ≠ j, and pii = 0.0 for all i. The end-of-file is denoted by a single line containing the number −1. Note that each of the matrix entries in this problem is given as a floating-point value. To avoid precision problems, make sure that you use either the double data type instead of float.

Output

The output file should contain a single line for each test case indicating the number of the team most likely to win. To prevent floating-point precision issues, it is guaranteed that the difference in win probability for the top two teams will be at least 0.01.

Sample Input

2
0.0 0.1 0.2 0.3
0.9 0.0 0.4 0.5
0.8 0.6 0.0 0.6
0.7 0.5 0.4 0.0
-1

Sample Output

2

Hint

In the test case above, teams 1 and 2 and teams 3 and 4 play against each other in the first round; the winners of each match then play to determine the winner of the tournament. The probability that team 2 wins the tournament in this case is:

P(2 wins) P(2 beats 1)P(3 beats 4)P(2 beats 3) + P(2 beats 1)P(4 beats 3)P(2 beats 4)
p21p34p23 + p21p43p24
= 0.9 · 0.6 · 0.4 + 0.9 · 0.4 · 0.5 = 0.396.

The next most likely team to win is team 3, with a 0.372 probability of winning the tournament.

Source


题意:2^n个球队进行n轮比赛,每2个队比赛都有一个胜出的概率,问哪一个队伍最后胜出概率最大,而且比赛顺序是按第一轮(1,2)(3,4)这样进行。
题解:这是一道概率dp的题目,设dp【i】【j】为第i场比赛第j个队胜出了的概率,所以dp【i】【j】需要枚举它这一轮的对手球队,用上一轮的胜出概率乘以对手上一轮的胜出概率乘以它打败这个对手的概率

#include<stdio.h>
#include<string.h>
#include<math.h>
double c[138][138],p[8][138];
int n,po[10];
int main()
{
    int i,j,k,l,temp,temp2,temp3;
    double temp4;

    for(po[0]=i=1;i<=8;i++) po[i]=po[i-1]*2; //2的i次方
    while(scanf("%d",&n)&&n!=-1)
    {
        for(i=1;i<=po[n];i++)
        {
            for(j=1;j<=po[n];j++)
                scanf("%lf",&c[i][j]);
        }
        for(i=0;i<=po[n];i++) p[0][i]=1;
        for(i=1;i<=n;i++)
        {
            temp=po[n]/po[i];
            for(j=1;j<=temp;j++)
            {
                temp2=(j-1)*po[i];
                temp3=(j-1)*po[i]+po[i-1];
                for(k=1;k<=po[i-1];k++)
                {
                    p[i][temp2+k]=0;
                    for(l=1;l<=po[i-1];l++)
                        p[i][temp2+k]+=p[i-1][temp2+k]*c[temp2+k][temp3+l]*p[i-1][temp3+l];
                }
                for(k=1;k<=po[i-1];k++)
                {
                    p[i][temp3+k]=0;
                    for(l=1;l<=po[i-1];l++)
                        p[i][temp3+k]+=p[i-1][temp3+k]*c[temp3+k][temp2+l]*p[i-1][temp2+l];
                }
            }
        }
        for(temp4=0,i=1;i<=po[n];i++)
            if(p[n][i]>temp4) temp=i,temp4=p[n][i];
        printf("%d\n",temp);
    }

    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值