hdu 1520 Anniversary party(树dp)

Anniversary party

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3354    Accepted Submission(s): 1528


Problem Description
There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.
 

Input
Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form: 
L K 
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 
0 0
 

Output
Output should contain the maximal sum of guests' ratings.
 

Sample Input
  
  
7 1 1 1 1 1 1 1 1 3 2 3 6 4 7 4 4 5 3 5 0 0
 

Sample Output
  
  
5
 

Source
 

Recommend
linle
 

题意:某大学有N个职员,编号为1~N。他们有从属关系,也就是说他们的关系就像一棵以校长为根的树,父结点就是子结点的直接上司。每个职员有一个快乐指数。现在有个周年庆宴会,要求与会职员的快乐指数最大。但是,没有职员愿和直接上司一起与会

题解:树dp

#include<stdio.h>
int fath[6008],val[6008],n;
int all,head[6008],dp[6008][2];
struct edge{
    int next,data;
}p[6888];
int MAX(int a,int b){ return a>b?a:b; }
void add(int x,int y)
{
    p[all].next=head[x];
    p[all].data=y;
    head[x]=all++;
}
void dfs(int x)
{
    int temp,i;

    dp[x][0]=0;  dp[x][1]=val[x];
    if(head[x]==-1) return;
    for(i=head[x];i!=-1;i=p[i].next)
    {
        temp=p[i].data;
        dfs(temp);
        dp[x][0]+=MAX(dp[temp][0],dp[temp][1]);
        dp[x][1]+=dp[temp][0];
    }
}
int main()
{
    int i,x,y;

    while(scanf("%d",&n)>0)
    {
        for(i=1;i<=n;i++)
        {
            scanf("%d",val+i);
            head[i]=fath[i]=-1;
        }
        for(all=i=0;i<n-1;i++)
        {
            scanf("%d%d",&x,&y);
            fath[x]=y;  add(y,x);
        }
        scanf("%d%d",&x,&y);
        for(i=1;i<=n;i++)
        {
            if(fath[i]!=-1) continue;
            dfs(i);  break;
        }
        printf("%d\n",MAX(dp[i][0],dp[i][1]));
    }

    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值