poj 3691 DNA repair(自动机+DP)

DNA repair
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 5142 Accepted: 2404

Description

Biologists finally invent techniques of repairing DNA that contains segments causing kinds of inherited diseases. For the sake of simplicity, a DNA is represented as a string containing characters 'A', 'G' , 'C' and 'T'. The repairing techniques are simply to change some characters to eliminate all segments causing diseases. For example, we can repair a DNA "AAGCAG" to "AGGCAC" to eliminate the initial causing disease segments "AAG", "AGC" and "CAG" by changing two characters. Note that the repaired DNA can still contain only characters 'A', 'G', 'C' and 'T'.

You are to help the biologists to repair a DNA by changing least number of characters.

Input

The input consists of multiple test cases. Each test case starts with a line containing one integers  N (1 ≤  N ≤ 50), which is the number of DNA segments causing inherited diseases.
The following  N lines gives  N non-empty strings of length not greater than 20 containing only characters in "AGCT", which are the DNA segments causing inherited disease.
The last line of the test case is a non-empty string of length not greater than 1000 containing only characters in "AGCT", which is the DNA to be repaired.

The last test case is followed by a line containing one zeros.

Output

For each test case, print a line containing the test case number( beginning with 1) followed by the
number of characters which need to be changed. If it's impossible to repair the given DNA, print -1.

Sample Input

2
AAA
AAG
AAAG    
2
A
TG
TGAATG
4
A
G
C
T
AGT
0

Sample Output

Case 1: 1
Case 2: 4
Case 3: -1

Source


题意:给定一些目标串和一个主串,问最少修改多少个字符才使主串不包含任意一个目标串
题解:建立AC自动机的trie树,总共就这么多个状态是有效的,然后在这些状态上用dp求解。。。本人也做了很久才弄懂,建议在这里看一下http://blog.csdn.net/human_ck/article/details/6577142

#include<stdio.h>
#include<string.h>
#define inf 0xffffff
struct trie
{
    int next[4],fail,flag;
}tree[1005];
int dp[1005][1005];
int que[1005],all;
char s[1005];
int MIN(int a,int b)
{
    return a<b?a:b;
}
void init(int x)
{
    memset(tree[x].next,0,sizeof(tree[x].next));
    tree[x].fail=0;
    tree[x].flag=0;
}
int change(char c)
{
    if(c=='A') return 0;
    else if(c=='T') return 1;
    else if(c=='C') return 2;
    else return 3;
}
void myinsert(char *str)
{
    int i,temp,now=0;

    for(i=0;str[i];i++)
    {
        temp=change(str[i]);
        if(!tree[now].next[temp])
        {
            init(++all);
            tree[now].next[temp]=all;
        }
        now=tree[now].next[temp];
    }
    tree[now].flag=1;
}
void mybuildac()
{
    int sta=0,fin=0,i,now;

    for(i=0;i<4;i++)
    {
        if(!tree[0].next[i]) continue;
        que[fin++]=tree[0].next[i];
    }
    while(sta<fin)
    {
        now=que[sta++];
        for(i=0;i<4;i++)
        {
            if(!tree[now].next[i]) tree[now].next[i]=tree[tree[now].fail].next[i];
            else
            {
                tree[tree[now].next[i]].fail=tree[tree[now].fail].next[i];
                if(tree[tree[tree[now].next[i]].fail].flag) tree[tree[now].next[i]].flag=1;
                que[fin++]=tree[now].next[i];
            }
        }
    }
}
int solve()
{
    int i,j,k,temp,res,len=strlen(s);

    for(i=0;i<=len;i++)
    {
        for(j=0;j<all;j++)
            dp[i][j]=inf;
    }
    dp[0][0]=0;
    for(i=1;i<=len;i++)
    {
        for(j=0;j<all;j++)
        {
            if(dp[i-1][j]<inf)
            {
                for(k=0;k<4;k++)
                {
                    if(!tree[tree[j].next[k]].flag)
                    {
                        temp=tree[j].next[k];
                        dp[i][temp]=MIN(dp[i][temp],dp[i-1][j]+(change(s[i-1])!=k));
                    }
                }
            }
        }
    }
    for(res=inf,i=0;i<all;i++)
    {
        if(tree[i].flag==0&&res>dp[len][i])
            res=dp[len][i];
    }

    return res<inf?res:-1;
}
int main()
{
    int i,n,cas=1;
    char str[28];

    while(scanf("%d",&n)&&n)
    {
        init(0);
        for(all=i=0;i<n;i++)
        {
            scanf("%s",str);
            myinsert(str);
        }
        mybuildac();
        scanf("%s",s);
        printf("Case %d: %d\n",cas++,solve());
    }

    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值