hdu 2838 Cow Sorting(树状数组)

Cow Sorting

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1617    Accepted Submission(s): 512


Problem Description
Sherlock's N (1 ≤ N ≤ 100,000) cows are lined up to be milked in the evening. Each cow has a unique "grumpiness" level in the range 1...100,000. Since grumpy cows are more likely to damage Sherlock's milking equipment, Sherlock would like to reorder the cows in line so they are lined up in increasing order of grumpiness. During this process, the places of any two cows (necessarily adjacent) can be interchanged. Since grumpy cows are harder to move, it takes Sherlock a total of X + Y units of time to exchange two cows whose grumpiness levels are X and Y.

Please help Sherlock calculate the minimal time required to reorder the cows.
 

Input
Line 1: A single integer: N
Lines 2..N + 1: Each line contains a single integer: line i + 1 describes the grumpiness of cow i.
 

Output
Line 1: A single line with the minimal time required to reorder the cows in increasing order of grumpiness.
 

Sample Input
  
  
3 2 3 1
 

Sample Output
  
  
7
Hint
Input Details Three cows are standing in line with respective grumpiness levels 2, 3, and 1. Output Details 2 3 1 : Initial order. 2 1 3 : After interchanging cows with grumpiness 3 and 1 (time=1+3=4). 1 2 3 : After interchanging cows with grumpiness 1 and 2 (time=2+1=3).
 

Source
 

Recommend
gaojie

题意:有n头牛,每头牛有唯一的脾气值 - - ,要交换牛的位置使其脾气值按升序排,例如交换相邻x和y的牛,需要花x+y个单位时间,求最少时间
题解:在对树状数组和线段树有更深入的理解后,发觉这里按顺序插入数 x 的话,开一个树状数组计算比它大的数的数目 y,这就是要交换的,再开一个树状计算比它大的数的总和 z,这样就可以由sum+=x*y+z;求出结果了

#include<stdio.h>
#include<string.h>
__int64 cc[100005];
int c[100005];
int low_bit(int x)
{
    return x&(-x);
}
void add1(int x,int y)
{
    while(x<100001)
    {
        cc[x]+=y;
        x+=low_bit(x);
    }
}
void add2(int x)
{
    while(x<100001)
    {
        c[x]++;
        x+=low_bit(x);
    }
}
__int64 sum1(int x)
{
    __int64 temp=0;
    while(x>0)
    {
        temp+=cc[x];
        x-=low_bit(x);
    }
    return temp;
}
__int64 sum2(int x)
{
    __int64 temp=0;
    while(x>0)
    {
        temp+=c[x];
        x-=low_bit(x);
    }
    return temp;
}
int main()
{
    int n,x,i;
    __int64 sum=0;

    while(scanf("%d",&n)>0)
    {
        memset(cc,0,sizeof(cc));
        memset(c,0,sizeof(c));
        for(i=0;i<n;i++)
        {
            scanf("%d",&x);
            sum=sum+sum1(100001)-sum1(x-1)+(i-sum2(x))*x;
            add1(x,x),add2(x);
        }
        printf("%I64d\n",sum);
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值