hdu 1556 Color the ball(线段树or树状数组)

                                                          Color the ball

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5441    Accepted Submission(s): 2912


Problem Description
N个气球排成一排,从左到右依次编号为1,2,3....N.每次给定2个整数a b(a <= b),lele便为骑上他的“小飞鸽"牌电动车从气球a开始到气球b依次给每个气球涂一次颜色。但是N次以后lele已经忘记了第I个气球已经涂过几次颜色了,你能帮他算出每个气球被涂过几次颜色吗?
 

Input
每个测试实例第一行为一个整数N,(N <= 100000).接下来的N行,每行包括2个整数a b(1 <= a <= b <= N)。
当N = 0,输入结束。
 

Output
每个测试实例输出一行,包括N个整数,第I个数代表第I个气球总共被涂色的次数。
 

Sample Input
  
  
3 1 1 2 2 3 3 3 1 1 1 2 1 3 0
 

Sample Output
  
  
1 1 1 3 2 1
 

Author
8600
 

Source
 

Recommend
LL
 

题解:区间更新线段树,lazy思想,计算的时候将所有tree值延后到 l==r 就是答案


线段树:

#include<stdio.h>
int tree[400500],flag;
void build(int l,int r,int pos)
{
    int mid=(l+r)/2;

    tree[pos]=0;
    if(l==r) return;
    build(l,mid,2*pos);
    build(mid+1,r,2*pos+1);
}
void add(int l,int r,int pos,int templ,int tempr)
{
    int mid=(l+r)/2;

    if(templ<=l&&r<=tempr)
    {
        tree[pos]++;
        return;
    }
    if(tempr<=mid) add(l,mid,2*pos,templ,tempr);
    else if(templ>mid) add(mid+1,r,2*pos+1,templ,tempr);
    else
    {
        add(l,mid,2*pos,templ,mid);
        add(mid+1,r,2*pos+1,mid+1,tempr);
    }
}
void cal_print(int l,int r,int pos)
{
    int mid=(l+r)/2;

    if(l==r)
    {
        if(flag) printf(" ");
        printf("%d",tree[pos]);
        flag=1;  return;
    }
    if(tree[pos])
    {
        tree[2*pos]+=tree[pos];
        tree[2*pos+1]+=tree[pos];
    }
    cal_print(l,mid,2*pos);
    cal_print(mid+1,r,2*pos+1);
}
int main()
{
    int i,n,a,b;

    while(scanf("%d",&n),n)
    {
        build(1,n,1);
        for(i=1;i<=n;i++)
        {
            scanf("%d%d",&a,&b);
            add(1,n,1,a,b);
        }
        flag=0,cal_print(1,n,1);
        printf("\n");
    }

    return 0;
}

树状数组:(每一个点的值+1代表后面所有点都涂了一次)

#include<stdio.h>
int tree[100005],n;
int low_bit(int x)
{
    return x&(-x);
}
void add(int x,int y)
{
    while(x<=n)
    {
        tree[x]+=y;
        x+=low_bit(x);
    }
}
int ques(int x)
{
    int temp=0;

    while(x>0)
    {
        temp+=tree[x];
        x-=low_bit(x);
    }

    return temp;
}
int main()
{
    int i,a,b;

    while(scanf("%d",&n),n)
    {
        for(i=0;i<=n;i++) tree[i]=0;
        for(i=1;i<=n;i++)
        {
            scanf("%d%d",&a,&b);
            add(a,1),add(b+1,-1);
        }
        for(i=1;i<n;i++) printf("%d ",ques(i));
        printf("%d\n",ques(i));
    }
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值