hdu 3535 AreYouBusy(背包)

                                                    AreYouBusy

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2308    Accepted Submission(s): 859


Problem Description
Happy New Term!
As having become a junior, xiaoA recognizes that there is not much time for her to AC problems, because there are some other things for her to do, which makes her nearly mad.
What's more, her boss tells her that for some sets of duties, she must choose at least one job to do, but for some sets of things, she can only choose at most one to do, which is meaningless to the boss. And for others, she can do of her will. We just define the things that she can choose as "jobs". A job takes time , and gives xiaoA some points of happiness (which means that she is always willing to do the jobs).So can you choose the best sets of them to give her the maximum points of happiness and also to be a good junior(which means that she should follow the boss's advice)?
 

Input
There are several test cases, each test case begins with two integers n and T (0<=n,T<=100) , n sets of jobs for you to choose and T minutes for her to do them. Follows are n sets of description, each of which starts with two integers m and s (0<m<=100), there are m jobs in this set , and the set type is s, (0 stands for the sets that should choose at least 1 job to do, 1 for the sets that should choose at most 1 , and 2 for the one you can choose freely).then m pairs of integers ci,gi follows (0<=ci,gi<=100), means the ith job cost ci minutes to finish and gi points of happiness can be gained by finishing it. One job can be done only once.
 

Output
One line for each test case contains the maximum points of happiness we can choose from all jobs .if she can’t finish what her boss want, just output -1 .
 

Sample Input
  
  
3 3 2 1 2 5 3 8 2 0 1 0 2 1 3 2 4 3 2 1 1 1 3 4 2 1 2 5 3 8 2 0 1 1 2 8 3 2 4 4 2 1 1 1 1 1 1 0 2 1 5 3 2 0 1 0 2 1 2 0 2 2 1 1 2 0 3 2 2 1 2 1 1 5 2 8 3 2 3 8 4 9 5 10
 

Sample Output
  
  
5 13 -1 -1
 

Author
hphp
 

Source
 

Recommend
zhouzeyong

题意:有 t 时间,n个集合的事件,每个集合有一种属性 s,若s==0 则至少做该集合(不是全部为0的集合)的一件事,若s==1 则最多做该集合的一件事,若s==2 则随意做多少件,每件事花费一定时间,获得一定开心值,问能获得的最大开心值
题解:判断每一个集合的 s 值,然后分 s==0 时dp【flag】【j】不能直接继承上一层dp【!flag】【j】的值,s==1 时只能通过上一层的 dp 值得出本层 dp 值,s == 2 时是01背包,可以继承上一层 dp 值,且可以通过本层和上一层的 dp 值得出本层 dp 值

#include<stdio.h>
#include<string.h>
#define INF 0xfffff
int c[105],g[105],dp[2][105];
int MAX(int a,int b)
{
    return a>b?a:b;
}
int main()
{
    int n,t,m,s,i,j,cc,flag;

    while(scanf("%d%d",&n,&t)>0)
    {
        for(flag=i=0;i<=t;i++) dp[0][i]=0;
        for(cc=1;cc<=n;cc++)
        {
            flag=!flag;
            scanf("%d%d",&m,&s);
            for(i=1;i<=m;i++) scanf("%d%d",c+i,g+i);
            if(s==0)
            {
                for(i=0;i<=t;i++) dp[flag][i]=-INF;
                for(i=1;i<=m;i++)
                    for(j=t;j>=c[i];j--)
                    dp[flag][j]=MAX(MAX(dp[flag][j],dp[flag][j-c[i]]+g[i]),dp[!flag][j-c[i]]+g[i]);
            }
            else if(s==1)
            {
                for(i=0;i<=t;i++) dp[flag][i]=dp[!flag][i];
                for(i=1;i<=m;i++)
                    for(j=t;j>=c[i];j--)
                    dp[flag][j]=MAX(dp[flag][j],dp[!flag][j-c[i]]+g[i]);
            }
            else
            {
                for(i=0;i<=t;i++) dp[flag][i]=dp[!flag][i];
                for(i=1;i<=m;i++)
                    for(j=t;j>=c[i];j--)
                    dp[flag][j]=MAX(MAX(dp[flag][j],dp[flag][j-c[i]]+g[i]),dp[!flag][j-c[i]]+g[i]);
            }
        }
        printf("%d\n",MAX(dp[flag][t],-1));
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值