pku 1463 Strategic game(树dp)

Strategic game
Time Limit: 2000MS Memory Limit: 10000K
Total Submissions: 5627 Accepted: 2561

Description

Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him? 

Your program should find the minimum number of soldiers that Bob has to put for a given tree. 

For example for the tree: 

the solution is one soldier ( at the node 1).

Input

The input contains several data sets in text format. Each data set represents a tree with the following description: 

  • the number of nodes 
  • the description of each node in the following format 
    node_identifier:(number_of_roads) node_identifier1 node_identifier2 ... node_identifiernumber_of_roads 
    or 
    node_identifier:(0) 

The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500);the number_of_roads in each line of input will no more than 10. Every edge appears only once in the input data.

Output

The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following:

Sample Input

4
0:(1) 1
1:(2) 2 3
2:(0)
3:(0)
5
3:(3) 1 4 2
1:(1) 0
2:(0)
0:(0)
4:(0)

Sample Output

1
2

Source


题意:给出一棵树 ,在某个节点上放置一个卫兵可以管辖周围所有与该节点相连的边,问最少需要放置多少个卫兵 ,能管辖所有的边。
题解: 节点不放置卫兵,则其父亲节点必放置卫兵以覆盖该边,自叶 节点向上的过程中,如果某节点含有未 被覆盖的通向子节点的边,则此节点 放置卫兵。

#include<stdio.h>
int fath[1508],head[1508];
int dp[1508][2],all,n;
struct edge{
    int next,data;
}p[1508];
int MAX(int a,int b)
{
    return a>b?a:b;
}
int MIN(int a,int b)
{
    return a<b?a:b;
}
void add(int x,int y)
{
    p[all].next=head[x];
    p[all].data=y;
    head[x]=all++;
}
void dfs(int x)
{
    int i,temp;

    dp[x][0]=0;  dp[x][1]=1;
    if(head[x]==-1) return;
    for(i=head[x];i!=-1;i=p[i].next)
    {
        temp=p[i].data;
        dfs(temp);
        dp[x][0]+=dp[temp][1];
        dp[x][1]+=MIN(dp[temp][0],dp[temp][1]);
    }
}
int main()
{
    int i,j,x,y,z;

    //freopen("t.txt","r",stdin);
    while(scanf("%d",&n)>0)
    {
        for(i=0;i<=n;i++) fath[i]=head[i]=-1;
        for(all=i=0;i<n;i++)
        {
            scanf("%d",&x);
            getchar();  getchar();
            scanf("%d",&y);
            getchar();
            for(j=0;j<y;j++)
            {
                scanf("%d",&z);
                fath[z]=x;  add(x,z);
            }
        }
        for(i=0;i<n;i++)
        {
            if(fath[i]!=-1) continue;
            dfs(i);  break;
        }
        printf("%d\n",MIN(dp[i][0],dp[i][1]));
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值