hdu 2196 Computer(树dp)

Computer

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2112    Accepted Submission(s): 1068


Problem Description
A school bought the first computer some time ago(so this computer's id is 1). During the recent years the school bought N-1 new computers. Each new computer was connected to one of settled earlier. Managers of school are anxious about slow functioning of the net and want to know the maximum distance Si for which i-th computer needs to send signal (i.e. length of cable to the most distant computer). You need to provide this information. 


Hint: the example input is corresponding to this graph. And from the graph, you can see that the computer 4 is farthest one from 1, so S1 = 3. Computer 4 and 5 are the farthest ones from 2, so S2 = 2. Computer 5 is the farthest one from 3, so S3 = 3. we also get S4 = 4, S5 = 4.
 

Input
Input file contains multiple test cases.In each case there is natural number N (N<=10000) in the first line, followed by (N-1) lines with descriptions of computers. i-th line contains two natural numbers - number of computer, to which i-th computer is connected and length of cable used for connection. Total length of cable does not exceed 10^9. Numbers in lines of input are separated by a space.
 

Output
For each case output N lines. i-th line must contain number Si for i-th computer (1<=i<=N).
 

Sample Input
  
  
5 1 1 2 1 3 1 1 1
 

Sample Output
  
  
3 2 3 4 4
 

Author
scnu
 

Recommend
lcy


题意:有很多部电脑连接,有边权,求离每一部电脑最远的电脑的距离

题解:2次dfs,第一次求离根最远的距离和次远距离,第二次从根开始刷新子结点最远距离


#include<stdio.h>
int head[10008],all,n;
int dp[10008][2],mark[10008][2];
struct edge{
    int next,data,len;
}p[20008];
void add(int x,int y,int z)
{
    p[all].next=head[x];
    p[all].data=y;
    p[all].len=z;
    head[x]=all++;
}
void dfs(int x,int tp)
{
    int i,temp;

    dp[x][0]=dp[x][1]=0;
    for(i=head[x];i!=-1;i=p[i].next)
    {
        temp=p[i].data;
        if(temp==tp) continue;
        dfs(temp,x);
        if(dp[temp][1]+p[i].len>dp[x][0])
        {
            dp[x][0]=dp[temp][1]+p[i].len;
            mark[x][0]=temp;
            if(dp[x][0]>dp[x][1])
            {
                temp=mark[x][0],mark[x][0]=mark[x][1],mark[x][1]=temp;
                temp=dp[x][0],dp[x][0]=dp[x][1],dp[x][1]=temp;
            }
        }
    }
}
void dfs2(int x,int tp)
{
    int i,temp,tmd;

    for(i=head[x];i!=-1;i=p[i].next)
    {
        temp=p[i].data;
        if(temp==tp) continue;
        if(temp==mark[x][1])
        {
            if(dp[x][0]+p[i].len>dp[temp][0])
            {
                dp[temp][0]=dp[x][0]+p[i].len;
                mark[temp][0]=x;
                if(dp[temp][0]>dp[temp][1])
                {
                    tmd=mark[temp][0],mark[temp][0]=mark[temp][1],mark[temp][1]=tmd;
                    tmd=dp[temp][0],dp[temp][0]=dp[temp][1],dp[temp][1]=tmd;
                }
            }
        }
        else
        {
            if(dp[x][1]+p[i].len>dp[temp][0])
            {
                dp[temp][0]=dp[x][1]+p[i].len;
                mark[temp][0]=x;
                if(dp[temp][0]>dp[temp][1])
                {
                    tmd=mark[temp][0],mark[temp][0]=mark[temp][1],mark[temp][1]=tmd;
                    tmd=dp[temp][0],dp[temp][0]=dp[temp][1],dp[temp][1]=tmd;
                }
            }
        }
        dfs2(temp,x);
    }
}
int main()
{
    int i,x,y;

    while(scanf("%d",&n)>0)
    {
        for(all=i=0;i<=n;i++)
            head[i]=mark[i][0]=mark[i][1]=-1;
        for(i=2;i<=n;i++)
        {
            scanf("%d%d",&x,&y);
            add(i,x,y);  add(x,i,y);
        }
        dfs(1,-1);
        dfs2(1,-1);
        for(i=1;i<=n;i++)
            printf("%d\n",dp[i][1]);
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值