poj3687 Labeling Balls

Labeling Balls
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 13417 Accepted: 3874

Description

Windy has N balls of distinct weights from 1 unit to N units. Now he tries to label them with 1 to N in such a way that:

  1. No two balls share the same label.
  2. The labeling satisfies several constrains like "The ball labeled with a is lighter than the one labeled with b".

Can you help windy to find a solution?

Input

The first line of input is the number of test case. The first line of each test case contains two integers, N (1 ≤ N ≤ 200) and M (0 ≤ M ≤ 40,000). The next M line each contain two integers a and b indicating the ball labeled with a must be lighter than the one labeled with b. (1 ≤ a, b ≤ N) There is a blank line before each test case.

Output

For each test case output on a single line the balls' weights from label 1 to label N. If several solutions exist, you should output the one with the smallest weight for label 1, then with the smallest weight for label 2, then with the smallest weight for label 3 and so on... If no solution exists, output -1 instead.

Sample Input

5

4 0

4 1
1 1

4 2
1 2
2 1

4 1
2 1

4 1
3 2

Sample Output

1 2 3 4
-1
-1
2 1 3 4
1 3 2 4

不得不说这出题人水平真是太高了。

题目的大体意思是给你n个质量从1~n的球,让你给他编号,条件满足

  1. 任何两个球的编号都不一样
  2. 编号满足一些约束,类似于“编号a的球比编号为b的球轻
然后求一个,喂如果有多重情况你说让轻的作为编号1,那不知道谁轻呢,不得不说这题水平太low。

最后发现必须要从大到小排,并且号大的优先,用优先队列,这个题输出的原来还是重量,我也是醉了.......

随便看看吧,这题。

#include <iostream>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <cstdio>
#include <queue>
#include <vector>
using namespace std;

int n,m;
int in[250];
vector<int>head[250];
int ans[250];
void tusort()
{
    int i;
    priority_queue<int>q;
    for(i=1;i<=n;++i)if(!in[i])q.push(i);
    int cnt=n,sum=0;
    while(!q.empty())
    {
        int k=q.top();
        q.pop();
        ans[k]=cnt--;
        sum++;
        int l=head[k].size();
        for(i=0;i<l;++i)
        {
            in[head[k][i]]--;
            if(!in[head[k][i]])q.push(head[k][i]);
        }
    }

    if(sum<n)printf("-1\n");
    else
    {
        for(i=1;i<=n-1;++i)printf("%d ",ans[i]);
        printf("%d\n",ans[n]);
    }

}

int main()
{
    int t;
    int i;
    int u,v;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        for(i=1; i<=n; ++i)
        {
            in[i]=0;
            head[i].clear();
        }
        while(m--)
        {
            scanf("%d%d",&u,&v);
            in[v]++;
            head[u].push_back(v);
        }
    tusort();
    }
    return 0;
}


对了这题还有一个巨坑,那就是有重边,我用的链表所以没什么卵用,没有影响。




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值