拓扑排序(好题)hdu3231

F.A.Q
Hand In Hand
Online Acmers
Forum | Discuss
Statistical Charts
Problem Archive
Realtime Judge Status
Authors Ranklist
 
      C/C++/Java Exams     
ACM Steps
Go to Job
Contest LiveCast
ICPC@China
Best Coder beta
VIP | STD Contests
Virtual Contests 
    DIY | Web-DIY beta
Recent Contests
Author ID 
Password 
  Register new ID

Box Relations

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 974    Accepted Submission(s): 356
Special Judge


Problem Description
There are   n  boxes   C1, C2, ..., Cn  in 3D space. The edges of the boxes are parallel to the   x, y  or   z-axis. We provide some relations of the boxes, and your task is to construct a set of boxes satisfying all these relations.

There are four kinds of relations (1 <=   i,j  <=   n,   i  is different from   j):
  • I i j: The intersection volume of Ci and Cj is positive.
  • X i j: The intersection volume is zero, and any point inside Ci has smaller x-coordinate than any point inside Cj.
  • Y i j: The intersection volume is zero, and any point inside Ci has smaller y-coordinate than any point inside Cj.
  • Z i j: The intersection volume is zero, and any point inside Ci has smaller z-coordinate than any point inside Cj.
.
 

Input
There will be at most 30 test cases. Each case begins with a line containing two integers   n  (1 <=   n  <= 1,000) and   R  (0 <=   R  <= 100,000), the number of boxes and the number of relations. Each of the following   R  lines describes a relation, written in the format above. The last test case is followed by   n= R=0, which should not be processed.
 

Output
For each test case, print the case number and either the word POSSIBLE or IMPOSSIBLE. If it's possible to construct the set of boxes, the   i-th line of the following n  lines contains six integers   x1, y1, z1, x2, y2, z2,  that means the   i-th box is the set of points ( x,y,z) satisfying   x1 <= x <= x2, y1 <= y <= y2, z1 <= z <= z2. The absolute values of   x1, y1, z1, x2, y2, z2  should not exceed 1,000,000.

Print a blank line after the output of each test case.
 

Sample Input
      
      
3 2 I 1 2 X 2 3 3 3 Z 1 2 Z 2 3 Z 3 1 1 0 0 0
 

Sample Output
      
      
Case 1: POSSIBLE 0 0 0 2 2 2 1 1 1 3 3 3 8 8 8 9 9 9 Case 2: IMPOSSIBLE Case 3: POSSIBLE 0 0 0 1 1 1


思路:每个盒子有六个面,i表示上表面,i+n表示下表面,然后根据给的关系建图,I表示a的上表面在b的下表面上面,a的下表面在b的上表面下面,x,y,z的操作相同,然后把x,y,z三维分别进行拓扑排序,如果能够进行得话,就说明存在这样的顺序。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<vector>
#include<cmath>
#include<queue>
#include<stack>
#include<map>
#include<set>
#include<algorithm>
using namespace std;
const int maxn=2010;
const int dimension=3;
int n,R;
vector<int> g[3][maxn];
int in[dimension][maxn];
void init()
{
    memset(in,0,sizeof(in));
    for(int i=0;i<dimension;i++)
        for(int j=0;j<=2*n;j++)g[i][j].clear();
    for(int i=0;i<dimension;i++)
        for(int j=1;j<=n;j++)
        {
            g[i][j].push_back(j+n);
            in[i][j+n]++;
        }
}
bool topo(int x[],int d)
{
    queue<int> q;
    for(int i=1;i<=2*n;i++)
        if(!in[d][i])
            q.push(i);
    int cnt=0;
    while(!q.empty())
    {
        int b=q.front();
        q.pop();
        x[b]=cnt++;
        int len=g[d][b].size();
        for(int i=0;i<len;i++)
            if(--in[d][g[d][b][i]]==0)q.push(g[d][b][i]);
    }
    for(int i=1;i<=2*n;i++)
        if(in[d][i])return false;
    return true;
}
void solve()
{
    int ans[dimension][maxn];
    for(int i=0;i<dimension;i++)
        if(!topo(ans[i],i)){printf("IMPOSSIBLE\n");return;}
    printf("POSSIBLE\n");
    for(int i=1;i<=n;i++)
        printf("%d %d %d %d %d %d\n",ans[0][i],ans[1][i],ans[2][i],ans[0][i+n],ans[1][i+n],ans[2][i+n]);
}
int main()
{
    int cas=1;
    while(scanf("%d%d",&n,&R)!=EOF,n||R)
    {
        init();
        while(R--)
        {
            char op[5];
            int x,y;
            scanf("%s%d%d",op,&x,&y);
            if(op[0]=='I')
            {
                for(int i=0;i<dimension;i++)
                {
                    g[i][x].push_back(y+n);
                    in[i][y+n]++;
                    g[i][y].push_back(x+n);
                    in[i][x+n]++;
                }
            }
            else
            {
                g[op[0]-'X'][x+n].push_back(y);
                in[op[0]-'X'][y]++;
            }
        }
        printf("Case %d: ",cas++);
        solve();
        printf("\n");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值