A Bug's Life 并查集

Description

Background 
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. 
Problem 
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.

Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

Hint

Huge input,scanf is recommended.

#include <stdio.h>
#include <stdlib.h>
#define MAX 2002 
int flag;
int father[MAX],rank[MAX];
int Find_set(int x){
	int tmp;
	if(x!=father[x]){
		tmp=father[x];
		father[x]=Find_set(father[x]);
		rank[x]^=rank[tmp];		//重新确定x和他祖先的 
		
	}
	return father[x];
}
void Union(int x,int y){
	int fx=Find_set(x);
	int fy=Find_set(y);
	father[fy]=fx;			//使x的祖先为y的祖先 
	rank[fy]=rank[x]^rank[y]^1;		//确定y的祖先与祖先的祖先的关系(是否同性);	
	return;
}
int main(){
	int T;
	int i,j,countx,county;
	int x,y,n,m;
	scanf("%d",&T);
	for(i=1;i<=T;i++){
		flag=1;
		scanf("%d%d",&n,&m);
		for(j=1;j<=n;j++){ 
			father[j]=j;
			rank[j]=0; 	//rank=0表示j和rank[j](他的祖先)同性;等于1表示异性; 
		}
		for(j=1;j<=m;j++){
			scanf("%d%d",&x,&y);
			if(flag){
				if(Find_set(x)!=Find_set(y))
					Union(x,y);
				else{
					if(rank[x]==rank[y])		//正常情况是x和y异性,但如果rank[x]等于rank[y],则x和y同性,所以后面的输入都不管了 
					flag=0;
				}				
			}
		}
		printf("Scenario #%d:\n",i);
		if(flag)
		printf("No suspicious bugs found!\n");
		else
		printf("Suspicious bugs found!\n");
		if(i!=T)
		printf("\n");
	}
	return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值