boj 321

Description
   There is a positive integer N, and please give us the smallest root x of equation sqrt(N)=sqrt(x)-sqrt(y) when x and y are both positive integer.

Input
   There are several test cases and end by EOF.
   Each line contain a positive integer N, 1<N≤2^31-1.

Output
   There is only one line for each test case.
   The line contains only one integer indicate the smallest x which meet the above conditions.


Sample Input
 4
 536


Sample Output
 9
 1206

 

思路:

sqrt(n)=sqrt(x)-sqrt(y)

=>x=n+y+2*sqrt(ny),y=x+n-2*sqrt(nx)

因为x,y为正整数,所以,nx和ny均为完全平方数

=>x=k^2*y

n=((k-1)/k))^2*x

令k-1=m

x=n*((m+1)/m)^2

即求最大的m使得n能被m的平方整除。

代码:

#include<iostream>
#include<cmath>
using namespace std;

int main()
{
	int n;
	while(~scanf("%d",&n))
	{
		long long x;
		for(int i=sqrt(double(n));i>=1;i--)
		{
			if(n%(i*i)==0)
			{
				int tmp=n/(i*i);
				x=tmp*(i+1)*(i+1);
				break;
			}
		}
		printf("%lld\n",x);
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值