Description
There are n cells in a sequence. You can use three kinds of colors, red , pink , green to paint these cells , one cell with only one kind of color . Promising that any two adjacent cells are painted with different colors and the color in the first cell is different from the color in the last cell . Now you need to calculate the total number of methods, meeting the given requirements, to paint these n cells.
Input
There are several test cases. Each test case is in one line with a integer N. (0 < n <= 50)
Output
For each test case, output the total number of the methods that meet the requirements. One answer a line , respectively.
Sample Input
1
2
Sample Output
3
6
思路:
递推公式:f(n)=f(n-1)+2*f(n-2)
代码:
#include<iostream>
using namespace std;
#define N 55
long long f[N];
int main()
{
int n;
f[1]=3;
f[2]=f[3]=6;
for(int i=4;i<=50;i++)
f[i]=f[i-1]+f[i-2]*2;
while(~scanf("%d",&n))
printf("%lld\n",f[n]);
}