boj 10

Description

 

There are n cells in a sequence. You can use three kinds of colors, red , pink , green to paint these cells , one cell with only one kind of color . Promising that any two adjacent cells are painted with different colors and the color in the first cell is different from the color in the last cell . Now you need to calculate the total number of methods, meeting the given requirements, to paint these n cells.

 

Input

 

There are several test cases. Each test case is in one line with a integer N. (0 < n <= 50)

 

Output

 

For each test case, output the total number of the methods that meet the requirements. One answer a line , respectively.

 

Sample Input

 

1

2

Sample Output

 

3

6

思路:

递推公式:f(n)=f(n-1)+2*f(n-2)

代码:

#include<iostream>
using namespace std;

#define N 55
long long f[N];

int main()
{
	int n;
	f[1]=3;
	f[2]=f[3]=6;
	for(int i=4;i<=50;i++)
		f[i]=f[i-1]+f[i-2]*2;
	while(~scanf("%d",&n))
		printf("%lld\n",f[n]);
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值