boj 12

Description
Big Johnsson Trucks Inc. is a company specialized in manufacturing big trucks. Their latest model, the Godzilla V12, is so big that the amount of cargo you can transport with it is never limited by the truck itself. It is only limited by the weight restrictions that apply for the roads along the path you want to drive.

Given start and destination city, your job is to determine the maximum load of the Godzilla V12 so that there still exists a path between the two specified cities.


Input
The input will contain one or more test cases. The first line of each test case will contain two integers: the number of cities n (2<=n<=200) and the number of road segments r (1<=r<=19900) making up the street network.
Then r lines will follow, each one describing one road segment by naming the two cities connected by the segment and giving the weight limit for trucks that use this segment. Names are not longer than 30 characters and do not contain white-space characters. Weight limits are integers in the range 0 - 10000. Roads can always be travelled in both directions.
The last line of the test case contains two city names: start and destination.
Input will be terminated by two values of 0 for n and r.


Output
For each test case, print three lines:

  • a line saying "Scenario #x" where x is the number of the test case

  • a line saying "y tons" where y is the maximum possible load

a blank line

Sample Input

4 3

Karlsruhe Stuttgart 100

Stuttgart Ulm 80

Ulm Muenchen 120

Karlsruhe Muenchen

5 5

Karlsruhe Stuttgart 100

Stuttgart Ulm 80

Ulm Muenchen 120

Karlsruhe Hamburg 220

Hamburg Muenchen 170

Muenchen Karlsruhe

0 0

Sample Output

Scenario #1

80 tons

 

 

Scenario #2

170 tons

 

大三的时候交了,一直CE,后来发现是自己变了命名的时候有个int count,可能与oj上的重复了,改成cnt后过了,就是用dijkstra,不过此时是寻找能承受最大重量的路径。

代码:

#include<iostream>
using namespace std;
int dp[300][300],weigh[300],flag[300],n,r,cnt;
char  f[300][35];
int find_num(char *a)
{
	bool flag_=0;
	int i;
	for(i=1;i<=cnt;i++)
	{
		if(strcmp(a,f[i])==0)
		{
			flag_=1;
			break;
		}
	}
	if(flag_==0)strcpy(f[++cnt],a);
	return i;
}
int main()
{
	int num=1;
	char start[20],endd[20];
	scanf("%d %d",&n,&r);
	while(!(n==0&&r==0))
	{
		memset(weigh,0,sizeof(weigh));
		memset(flag,0,sizeof(flag));
		memset(dp,0,sizeof(dp));
		int i;
		cnt=0;
		for(i=0;i<r;i++)
		{
			char x[20],y[20];
			int weight,xi,yi;
			scanf("%s %s %d",x,y,&weight);
			xi=find_num(x);
			yi=find_num(y);
			if(!dp[xi][yi])
				dp[xi][yi]=dp[yi][xi]=weight;
			else
				dp[xi][yi]=dp[yi][xi]=min(weight,dp[xi][yi]);
		}
		scanf("%s %s",start,endd);
		int sta=find_num(start);
		int end=find_num(endd);
		weigh[sta]=10003;
		for(i=0;i<n;i++)
		{
			int x,m=0;
			for(int y = 1;y <= n;y++)if(!flag[y] && weigh[y]>=m) m = weigh[x=y];
			flag[x]=1;
			for(int y = 1;y <=n;y++)
			{
				if(weigh[y]<min(weigh[x],dp[x][y]))
					weigh[y]=min(weigh[x],dp[x][y]);
			}
		}
		printf("Scenario #%d\n%d tons\n\n",num++,weigh[end]);
		scanf("%d %d",&n,&r);
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值