boj 447

Description
Let’s play a stone removing game.

Initially, n stones are arranged on a circle and numbered 1, …, n clockwise (Figure 1). You are also given two numbers k and m. From this state, remove stones one by one following the rules explained below, until only one remains. In step 1, remove stone m. In step 2, locate the k-th next stone clockwise from m and remove it. In subsequent steps, start from the slot of the stone removed in the last step, make k hops clockwise on the remaining stones and remove the one you reach. In other words, skip (k − 1) remaining stones clockwise and remove the next one. Repeat this until only one stone is left and answer its number. For example, the answer for the case n = 8, k = 5, m = 3 is 1, as shown in Figure 1.



Initial state: Eight stones are arranged on a circle.

Step 1: Stone 3 is removed since m = 3.

Step 2: You start from the slot that was occupied by stone 3. You skip four stones 4, 5, 6 and 7 (since k = 5), and remove the next one, which is 8.

Step 3: You skip stones 1, 2, 4 and 5, and thus remove 6. Note that you only count stones that are still on the circle and ignore those already removed. Stone 3 is ignored in this case.

Steps 4–7: You continue until only one stone is left. Notice that in later steps when only a few stones remain, the same stone may be skipped multiple times. For example, stones 1 and 4 are skipped twice in step 7.

Final State: Finally, only one stone, 1, is on the circle. This is the final state, so the answer is 1.



Input
The input consists of multiple datasets each of which is formatted as follows.

n k m

The last dataset is followed by a line containing three zeros. Numbers in a line are separated by a single space. A dataset satisfies the following conditions.

2 ≤ n ≤ 10000, 1 ≤ k ≤ 10000, 1 ≤ m ≤ n

The number of datasets is less than 100.


Output
For each dataset, output a line containing the stone number left in the final state. No extra characters such as spaces should appear in the output.


Sample Input

8 5 3
100 9999 98
10000 10000 10000
0 0 0


Sample Output

1
93
2019


Source
tokyo 2007

 

约瑟夫环问题,n个人编号1~n围成一圈报数,报到m的人出列,循环,找最后剩下的人编号。

初始序列为:1,2,3,4,5...m-1,m,m+1...n

去掉一个人后:1,2,3,4,5...m-1,m+1...n

m+1,m+2...n...1,2,3,...m-1

做如下变换:

m+1->1

m+2->2

....

....

m-1->n-1

则序列为:1,2,3,4,...n-1

变成了n-1个人报数的问题,递归求解,设n-1个人的解为x,易得在原始序列中的解为(x+m)%n(注意模为0的情况,即解为n);

此题要注意的就是第一次是报m,后面全部报k

代码:

#include<iostream>
using namespace std;
int main()
{
	int n,k,m;
	scanf("%d %d %d",&n,&k,&m);
	while(!(n==0&&m==0&&k==0))
	{
		int tmp = 1;
		for(int i =2;i<n;i++)
		{
			tmp = (tmp+k)%i;
			if(tmp==0)
				tmp = i;
		}
		tmp = (tmp+m)%n;
		if(tmp==0)
			tmp = n;
		printf("%d\n",tmp);
		scanf("%d %d %d",&n,&k,&m);
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值