hdu 2054 A == B ?

   这道题是我刚接触ACM的时候的一道题,那是连大数都不知道,

以为这是一道水题,结果没过,今天又看见啦,就做一下啦,

结果又wa了好几次才过~

  

A == B ?

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 50258    Accepted Submission(s): 7749


Problem Description
Give you two numbers A and B, if A is equal to B, you should print "YES", or print "NO".
 

Input
each test case contains two numbers A and B.
 

Output
for each case, if A is equal to B, you should print "YES", or print "NO".
 

Sample Input
  
  
1 2 2 2 3 3 4 3
 

Sample Output
  
  
NO YES YES NO
 

#include <iostream>
#include <cstring>
#include <cstdio>
#include<cmath>
#include <algorithm>
using namespace std;
char s[100005],b[100005];
char* solve(char *a)
  {
      int t=strlen(a);

    if(strchr(a,'.')!=NULL)
      {

      while(a[--t]=='0');
      if(a[t]=='.')
        t--;
      a[t+1]='\0';
      }//去除后缀零
     while(a[0]=='0')
       {
         for(int j=0;j<t-1;j++)
          a[j]=a[j+1];
          a[t--]='\0';

       }//去除前缀零
    return a;
  }

int main()
{

     int i;
   while(~scanf("%s%s",s,b))
   {
      if(strcmp(solve(s),solve(b))==0)
        printf("YES\n");
      else
        printf("NO\n");
   }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值