poj 1017 Packets ( 贪心 )

Packets
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 40110 Accepted: 13424

Description

A factory produces products packed in square packets of the same height h and of the sizes 1*1, 2*2, 3*3, 4*4, 5*5, 6*6. These products are always delivered to customers in the square parcels of the same height h as the products have and of the size 6*6. Because of the expenses it is the interest of the factory as well as of the customer to minimize the number of parcels necessary to deliver the ordered products from the factory to the customer. A good program solving the problem of finding the minimal number of parcels necessary to deliver the given products according to an order would save a lot of money. You are asked to make such a program.

Input

The input file consists of several lines specifying orders. Each line specifies one order. Orders are described by six integers separated by one space representing successively the number of packets of individual size from the smallest size 1*1 to the biggest size 6*6. The end of the input file is indicated by the line containing six zeros.

Output

The output file contains one line for each line in the input file. This line contains the minimal number of parcels into which the order from the corresponding line of the input file can be packed. There is no line in the output file corresponding to the last ``null'' line of the input file.

Sample Input

0 0 4 0 0 1 
7 5 1 0 0 0 
0 0 0 0 0 0 

Sample Output

2 
1 

Source


题意:
有1*1、2*2、3*3、4*4、5*5、6*6的物品,运货公司用6*6的箱子装,要求把所有物品放进箱子中,
怎样使箱子最少。

分析:
首先分析:
每个4*4、5*5、6*6的物品需要一个6*6的盒子。然后剩余空间可装小物品。
5*5的盒子剩余空间可装11个1*1
4*4的盒子剩余空间可装5个2*2和若干(不需算,因为可以用整个面积统计1*1的空位)个1*1
6*6的盒子可以装4个3*3

这样,为了使需要的盒子最少,其实我们的思路也暗示了
应该先装 大的物品

用向上取整的方式统计箱子个数
用面积统计来算1*1的空位

  向上取整:类比向上取整函数的作用,其实就是在小数a上+1再取整数部分,
                        即(a+1)/1。
 相似地,对3*3的物品,由于一个盒子可装4个
 每次需要的盒子就是  (box[3]+3)/4

代码:
#include<cstdio>
int t[4]={0,5,3,1};
int box[7];
int main()
{
    while(1)
    {
        int tmp=0,i;
        for(i=1;i<=6;i++)
        {
            scanf("%d",&box[i]);
            tmp+=box[i];
        }
        if(tmp==0)
            break;
        int ans=box[6]+box[5]+box[4]+(box[3]+3)/4;
        int a2=box[4]*5+t[box[3]%4];
        if(box[2]>a2)
            ans+=((box[2]-a2)+8)/9;
        int a1=ans*36-box[6]*36-box[5]*25-box[4]*16-box[3]*9-box[2]*4;
        if(box[1]>a1)
            ans+=(box[1]-a1+35)/36;
        printf("%d\n",ans);
    }
    return 0;
}

12012408

fukan

1017

Accepted

164K

16MS

C++

595B

2013-08-20 08:32:32


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值