POJ 2406 Power Strings:KMP算法

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed。

思路:用KMP算法,但是刚开始不知道怎么判断重复多少次,所以写出了那个next的每个值了才知道怎么判断。
#include <iostream>
#include <map>
#include <string>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;
char s[1000005];
int next[1000005],len;
int getnext()
{
    int k = -1,j = 0,x;
    next[0] = -1;
    while(j < len)
    {
        if(k == -1 ||s[j] == s[k]) next[++j] = ++k;
        else k = next[k];
    }
    x=j-next[j];   //或者可以写成x=len-k;都一样的
    if(len%x==0) return len/x;
    return 1;
}
int main()
{
    while(scanf("%s",s)&&s[0]!='.')
    {
        len=strlen(s);
        printf("%d\n",getnext());
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值