poj 2406 Power Strings(kmp算法)

题目链接:http://poj.org/problem?id=2406


Power Strings
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 31957 Accepted: 13322

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

Source

[Submit]   [Go Back]   [Status]   [Discuss]

Home Page   Go Back  To top



这道题其实是考KMP中fail数组的运用。题意要求一个字符串中循环节的个数。

对于字符串 pat ,若fail[j]=k 则 pat[0..k]=pat[j-k,j]如果总长度是这个循环节长度的整数倍,那么循环节的个数就是这个倍数。反之,说明这个字符串并不是在不停地循环,而是在某些位置加入了一个或几个不"和谐"的字符,导致指针无法回溯到第一个循环节之后,这样,输出1就可以了。

详细的可以瞧瞧这个博客http://www.cnblogs.com/coredux/archive/2012/08/13/2635987.html

#include<iostream>
#include<cstring>
#include<cmath>
#include<cstdio>
#include<algorithm>
#include<cstdlib>
#include<map>
#include<set>
#include<vector>
#include<string>
#include<stack>
#include<queue>
#include<bitset>
using namespace std;
#define CLR  memset(A,0,sizeof(A))
const int MAX=1000005;
int fail[MAX];
char str[MAX];
int kmp(char *pat){
    int len=strlen(pat);
    memset(fail,-1,sizeof(fail));
    for(int i=1;pat[i];i++){
        int k;
        for(k=fail[i-1];k>=0&&pat[i]!=pat[k+1];k=fail[k]);
        if(pat[k+1]==pat[i]){
            fail[i]=k+1;
        }
    }
  //  for(int i=0;i<=len;i++) cout<<fail[i]<<endl;
    int t=len-1-fail[len-1];
    if(len%t==0) return len/t;
    return 1;
}
int main(){
    while(~scanf("%s",str)&&str[0]!='.'){
        cout<<kmp(str)<<endl;
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值