Prime Ring Problem hdu 1016

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 20837    Accepted Submission(s): 9318


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input
  
  
6 8
 

Sample Output
  
  
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
 

Source
 

Recommend
JGShining
 
 
 
 
这是素数环的经典问题,就是用bfs 来做了,之前可以把素数都找到,就可以省下很多时间了。
 
 
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int n;
int maze[30];
int a[30];
int prime(int a,int b)
{
    int sum=a+b;
    int pri[12]= {2,3,5,7,11,13,17,19,23,29,31,37};
    int i;
    for(i=0; i<12; i++)
    {
        if(sum==pri[i])
        {
            return 1;
            break;
        }
    }
    return 0;

}

int dfs(int n,int num)
{
    int i;
    if((num==n)&&(prime(a[n-1],a[0])))
    {
        for(i=0; i<n-1; i++)
        printf("%d ",a[i]);
        printf("%d\n",a[n-1]);
    }
    else
    {
        for(i=2; i<=n; i++)
        {
            if((maze[i]==0)&&(prime(i,a[num-1])))
            {
                a[num]=i;
                maze[i]=1;
                dfs(n,num+1);
                maze[i]=0;

            }

        }


    }



}


int main()
{
    int i,j,k;
    int l=1;
    while(scanf("%d",&n)!=EOF)
    {
        memset(maze,0,sizeof(maze));
        printf("Case %d:\n",l);
        l++;
        a[0]=1;
        dfs(n,1);
        printf("\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值