Hello Kiki hdu 3579 求解一元线性同余方程组ps:中国剩余定理

Hello Kiki

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1833    Accepted Submission(s): 648


Problem Description
One day I was shopping in the supermarket. There was a cashier counting coins seriously when a little kid running and singing "门前大桥下游过一群鸭,快来快来 数一数,二四六七八". And then the cashier put the counted coins back morosely and count again...
Hello Kiki is such a lovely girl that she loves doing counting in a different way. For example, when she is counting X coins, she count them N times. Each time she divide the coins into several same sized groups and write down the group size Mi and the number of the remaining coins Ai on her note.
One day Kiki's father found her note and he wanted to know how much coins Kiki was counting.
 

Input
The first line is T indicating the number of test cases.
Each case contains N on the first line, Mi(1 <= i <= N) on the second line, and corresponding Ai(1 <= i <= N) on the third line.
All numbers in the input and output are integers.
1 <= T <= 100, 1 <= N <= 6, 1 <= Mi <= 50, 0 <= Ai < Mi
 

Output
For each case output the least positive integer X which Kiki was counting in the sample output format. If there is no solution then output -1.
 

Sample Input
  
  
2 2 14 57 5 56 5 19 54 40 24 80 11 2 36 20 76
 

Sample Output
  
  
Case 1: 341 Case 2: 5996
 

Author
digiter (Special Thanks echo)
 

Source
 

Recommend
zhouzeyong   |   We have carefully selected several similar problems for you:   3573  3574  3575  3576  3577 








题意是说有个小孩有钱,然后她每次都点m次,给出分的组数和剩余的钱数,求解最小的钱数。这个题目很明显同余方程组的求解 ,题目要求最小正整数解,如果求出同余方程组的解为0,则输出mi的最小公倍数


#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define N  15

long long gcd(long long a,long long b)
{
    return b==0?a:gcd(b,a%b);
}
void exgcd(long long a,long long b,long long &d,long long &x,long long &y)
{
    if(!b)
    {
        x=1;
        y=0;
        d=a;
    }
    else
    {
        exgcd(b,a%b,d,y,x);
        y=y-x*(a/b);
    }
}

long long aa[N],rr[N];
int main()
{
    long long n,a,b,c,d,x,y,lcm;
    
    int T,i,m;
    int e=1;
    scanf("%d",&T);
     for(e=1;e<=T;e++)
    {
        lcm=1;
        scanf("%d",&m);
        int ha=1;
        //printf("aaaaaa");
        //printf("%d\n",m);
        for(i=1; i<=m; i++)
        {
            cin>>aa[i];
            //printf("%d %d\n",i,m);
            // if(i==m)break;
            //printf("fdsfdsbbbbbbb");
            lcm=lcm/gcd(aa[i],lcm)*aa[i];
        }
       // printf("eeeeeeeeeeeeee");
        for(i=1; i<=m; i++)
        {
            scanf("%lld",&rr[i]);
        }

        printf("Case %d: ",e);
        for(i=2; i<=m; i++)
        {
            a=aa[1];
            b=aa[i];
            c=rr[i]-rr[1];
            exgcd(a,b,d,x,y);
            if(c%d!=0)
            {
                ha=0;
                break;
            }
            long long t=b/d;
            x=(x*(c/d)%t+t)%t;
            rr[1]=aa[1]*x+rr[1];
            aa[1]=aa[1]*(aa[i]/d);
        }
        if(!ha)
        {
            printf("-1\n");
            continue;
        }
        if(rr[1]!=0)
        {
            printf("%lld\n",rr[1]);
            continue;
        }
        printf("%lld\n",lcm);
    }
    return 0;
}





 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值