Power Strings poj 2406 kmp的运用

Power Strings
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 29264 Accepted: 12239

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

Source


这个题目还是不难的,题意是给出abcd,看成是数字相乘,求出最大幂是多少就是了,列如为abcd相当于

a^1*b^1*c^1*d^1得出,其中的最大幂也就是1了,用kmp来做的,分为两种情况,首先用l-next{l}求出其

循环节,列如当时ababab时,循环节就是ab,也就是2,那么幂也就是l/(l-next[l]),当然还有另外一种

情况,比如说当我们ababa,时循环节求出为2,但是最后一个没有b,没有办法整除,所以直接输出1是最好的

选择.



#include<iostream>
#include<string.h>
#include<cstdio>
#define M 1000010
using namespace std;
int la;
int next[M];
char s1[M];
void getNext()
{
    int j=-1;
    int i=0;
    next[0]=-1;
    while(i<la)
    {
        if(j==-1||s1[i]==s1[j])
        {
            i++;
            j++;
            next[i]=j;
        }
        else
            j=next[j];
    }
}

int main()
{
    while(scanf("%s",s1))
    {
        if(s1[0]=='.')
        break;
        la=strlen(s1);
        getNext();
        if(la%(la-next[la])==0)
        printf("%d\n",la/(la-next[la]));
        else
        printf("1\n");






    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值