HDU 1423 子序列

Greatest Common Increasing Subsequence


Problem Description
This is a problem from ZOJ 2432.To make it easyer,you just need output the length of the subsequence.
 

Input
Each sequence is described with M - its length (1 <= M <= 500) and M integer numbers Ai (-2^31 <= Ai < 2^31) - the sequence itself.
 

Output
output print L - the length of the greatest common increasing subsequence of both sequences.
 

Sample Input
  
  
1 5 1 4 2 5 -12 4 -12 1 2 4
 

Sample Output
  
  
2

求两个序列的最长公共递增子序列

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

const int maxn=555;
int a[maxn],b[maxn],len[maxn];
int n,m;//a,b数组的长度
int LCIS()
{
	int locate;
	memset(len,0,sizeof(len));
	for(int i=1;i<=n;++i)
	{
		locate=1;
		for(int j=1;j<=m;++j)
		{
			if(b[j]<a[i]&&len[j]>len[locate])
				locate=j;
			if(a[i]==b[j])
				len[j]=len[locate]+1;
		}
	}
	int max=-1;
	for(int i=1;i<=m;i++)
		max=max>len[i]?max:len[i];
	return max;
}

int main()
{
	int t;
	scanf("%d",&t);
	int i,j;
	while(t--)
	{
		scanf("%d",&n);
		for(i=1;i<=n;++i)
			scanf("%d",&a[i]);
		scanf("%d",&m);
		for(i=1;i<=m;++i)
			scanf("%d",&b[i]);
		int ans=LCIS();
		printf("%d\n",ans);
		if(t)
			printf("\n");
	}
	return 0;
}



 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值