POJ 1679 判断最小生成树是否有多种情况

The Unique MST
 

Description

Given a connected undirected graph, tell if its minimum spanning tree is unique.

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V', E'), with the following properties:
1. V' = V.
2. T is connected and acyclic.

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E') of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E'.

Input

The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.

Output

For each input, if the MST is unique, print the total cost of it, or otherwise print the string 'Not Unique!'.

Sample Input

2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2

Sample Output

3
Not Unique!
判断最小生成树是否有多种情况 ,加了多加了三个判断条件..做了一个多小时...无力啊
#include <iostream>
#include <algorithm>
using namespace std;
const int maxn=11111;
struct edge
{
	int s,e;//起始点
	int ss;//权值
	int equal;//标记是否有与其相同的权值(1、0)
	int vis;//标记第一次求的Mst中,是否包含该边
	int del;//标记改变是否被删除
}g[maxn];
int n,m;//顶点数、边数
int i,j;
int p[maxn];
bool first;
bool cmp(edge x,edge y)
{
	return x.ss<y.ss;
}
int find(int x)//寻找父结点
{
	if(x!=p[x])
		p[x]=find(p[x]);
	return p[x];
}
bool merge(int a,int b)//合并
{
	int x=find(a);
	int y=find(b);
	if(x!=y)
	{
		p[x]=y;//将x的父节点更新为y
		return true;//从而将树x,y合并成一棵树
	}
	return false;
}
int kruskal()
{
	for(i=1;i<=n;i++)//初始化,将各顶点的父节点标记为本身
		p[i]=i;
	sort(g+1,g+m+1,cmp);
	int sum=0,num=0;
	for(i=1;i<=m;i++)//m=n*(n-1)/2  遍历所有的边
	{
		if(g[i].del)
			continue;
		if(merge(g[i].s,g[i].e))
		{
			sum+=g[i].ss;
			num++;
			if(first)
				g[i].vis=1;
		}
		if(num>n)break;
	}
	return sum;
}
int main()
{
	int s,e,ss;
	int t,k;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		for(i=1;i<=m;i++)
		{
			scanf("%d%d%d",&s,&e,&ss);
			g[i].s=s;
			g[i].e=e;
			g[i].ss=ss;
			g[i].equal=g[i].vis=g[i].del=0;
		}
		for(i=1;i<=m;i++)//标记相同权值的边
		{
			for(j=1;j<=m;j++)
			{
				if(j==i)
					continue;
				else if(g[j].ss==g[i].ss)
					g[i].equal=1;
			}
		}
		first=true;
		int sum1=kruskal(),sum2;//第一次求MST
//		cout<<"sum1="<<sum1<<endl;
		first=false;
		for(k=1;k<=m;k++)
		{//依次去掉原MST中相同全职的边
			if(g[k].vis&&g[k].equal)
			{
				g[k].del=1;
				sum2=kruskal();
				if(sum1==sum2)
				{
					printf("Not Unique!\n");
					break;
				}
				g[k].del=0;//回溯
			}
		}
		if(k>m)
			printf("%d\n",sum1);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值