HDU 1829 并查集

A Bug's Life


Problem Description
Background 
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.  

Problem 
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.
 

Input
The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
 

Output
The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.
 

Sample Input
  
  
2 3 3 1 2 2 3 1 3 4 2 1 2 3 4
 

Sample Output
  
  
Scenario #1: Suspicious bugs found! Scenario #2: No suspicious bugs found!
Hint
Huge input,scanf is recommended.
 
//求是否有同性恋,只要把异性分在两个不同的集合里面,然后只要同一个集合里面有相连的,就是存在同性恋
#include <iostream>
using namespace std;
int p[111111],f[111111],flag;
int find(int x)
{
    if(x!=p[x])
        p[x]=p[find(p[x])];
    return p[x];
}
void merge(int x,int y)
{
    x=find(x),y=find(y);
    if(x==y)
    {
        flag=1;
        return;
    }
    if(f[x])p[f[x]]=y;
    if(f[y])p[f[y]]=x;
    f[x]=y,f[y]=x;
}
int main()
{
    int t,n,m,a,b,i,j,k,l;
    scanf("%d",&t);
    for(l=1;l<=t;l++)
    {
        scanf("%d%d",&n,&m);
        for(i=1;i<=n;i++)
            p[i]=i,f[i]=0;
        flag=0;
        while(m--)
        {
            scanf("%d%d",&a,&b);
            merge(a,b);
        }
        printf("Scenario #%d:\n",l);
        if(flag)puts("Suspicious bugs found!\n");
        else puts("No suspicious bugs found!\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值