hdu 1250 Hat's Fibonacci

Hat's Fibonacci

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6343    Accepted Submission(s): 2111


Problem Description

 

A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.
F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input, and print that Fibonacci number.
 


 

Input

 

Each line will contain an integers. Process to end of file.
 


 

Output

 

For each case, output the result in a line.
 


 

Sample Input

 

  
  
100
 


 

Sample Output

 

  
  
4203968145672990846840663646 Note: No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.
 

 

#include<stdio.h>
#include<math.h>
#include<string.h>
#include<stdlib.h>
#define M 510
const int T=10000;
int a[M],b[M],c[M],d[M],f[M];
void Fibo(int n)
{
	int i,j;
	a[0]=1;
	b[0]=1;
	c[0]=1;
	d[0]=1;
	for(i=5;i<=n;i++)
	{
		for(j=0;j<M;j++)
			f[j]=a[j]+b[j]+c[j]+d[j];
		for(j=0;j<M;j++)
			if(f[j]>=T)
			{
				f[j+1]+=f[j]/T;
				f[j]%=T;
			}
		for(j=0;j<M;j++)
		{
			a[j]=b[j];b[j]=c[j];
			c[j]=d[j];d[j]=f[j];
		}
	}
}
int main()
{
	int i,j,flag,n;
	while(scanf("%d",&n)!=-1)
	{
		if(n<5)
		{
			printf("1\n");
			continue;
		}
		memset(a,0,sizeof(a));
    	memset(b,0,sizeof(b));
    	memset(c,0,sizeof(c));
    	memset(d,0,sizeof(d));
    	memset(f,0,sizeof(f));
		Fibo(n);
		flag=0;
		for(i=M-1;i>=0;i--)
		{
			if(flag)
				printf("%04d",f[i]);
			else if(f[i])
			{
				printf("%d",f[i]);
				flag=1;
			}
		}
		printf("\n");
	}
	return 0;
}



 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值