Time Limit: 3000MS | Memory Limit: 65536K | |
Total Submissions: 50914 | Accepted: 17537 |
Description
A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome.
As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.
As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.
Input
Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.
Output
Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.
Sample Input
5 Ab3bd
Sample Output
2最长公共子序列问题(LCS):
需要加的字符的个数=原来字符串的长度-原来字符串和逆字符串的最长公共子序列的长度。
用滚动数组或用short int防止超内存。
<pre name="code" class="cpp">#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
#include<queue>
#include<vector>
#include<math.h>
using namespace std;
#define N 5005
#define ll long long
const int inf=0x1f1f1f1f;
char s[N],t[N];
int dp[2][N];
int main()
{
//freopen("in.txt","r",stdin);
//freopen("out.txt","w",stdout);
int i,j,n;
int u,v;
while(scanf("%d",&n)!=-1)
{
scanf("%s",s);
for(i=0;i<n;i++)
t[i]=s[n-1-i];
memset(dp,0,sizeof(dp));
for(i=1;i<=n;i++)
{
u=i%2;
v=(i-1)%2;
for(j=1;j<=n;j++)
{
if(s[i-1]==t[j-1])
dp[u][j]=dp[v][j-1]+1;
else
dp[u][j]=max(dp[u][j-1],dp[v][j]);
//printf("%d ",dp[i][j]);
}
}
printf("%d\n",n-dp[n%2][n]);
}
return 0;
}